about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/source-han-code-jp/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/data/fonts/source-han-code-jp/default.nix b/pkgs/data/fonts/source-han-code-jp/default.nix
new file mode 100644
index 000000000000..fc016a457c22
--- /dev/null
+++ b/pkgs/data/fonts/source-han-code-jp/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchzip }:
+
+let
+  pname = "source-han-code-jp";
+  version = "2.011R";
+in fetchzip {
+  name = "${pname}-${version}";
+
+  url = "https://github.com/adobe-fonts/${pname}/archive/${version}.zip";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts
+    unzip -j $downloadedFile \*.otf -d $out/share/fonts/opentype
+  '';
+
+  sha256 = "184vrjkymcm29k1cx00cdvjchzqr1w17925lmh85f0frx7vwljcd";
+
+  meta = {
+    description = "A monospaced Latin font suitable for coding";
+    maintainers = with stdenv.lib.maintainers; [ mt-caret ];
+    platforms = with stdenv.lib.platforms; all;
+    homepage = https://blogs.adobe.com/CCJKType/2015/06/source-han-code-jp.html;
+    license = stdenv.lib.licenses.ofl;
+  };
+}