about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorPascal Wittmann <mail@pascal-wittmann.de>2018-07-02 18:42:14 +0200
committerGitHub <noreply@github.com>2018-07-02 18:42:14 +0200
commita444ed38702c706dd5c38d5412503f05eb021ae0 (patch)
treeef06cbb022d328bdf6b1781c028bdd1db30038b4 /pkgs/data
parent8b312db421ca99797e60d76201f607f75c80af48 (diff)
parent95175cff45d7b19e7f91a58f46de2421fdc22e62 (diff)
downloadnixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar.gz
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar.bz2
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar.lz
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar.xz
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.tar.zst
nixlib-a444ed38702c706dd5c38d5412503f05eb021ae0.zip
Merge pull request #42827 from mt-caret/master
source-han-code-jp: init at 2.011R
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/source-han-code-jp/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/data/fonts/source-han-code-jp/default.nix b/pkgs/data/fonts/source-han-code-jp/default.nix
new file mode 100644
index 000000000000..fc016a457c22
--- /dev/null
+++ b/pkgs/data/fonts/source-han-code-jp/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchzip }:
+
+let
+  pname = "source-han-code-jp";
+  version = "2.011R";
+in fetchzip {
+  name = "${pname}-${version}";
+
+  url = "https://github.com/adobe-fonts/${pname}/archive/${version}.zip";
+
+  postFetch = ''
+    mkdir -p $out/share/fonts
+    unzip -j $downloadedFile \*.otf -d $out/share/fonts/opentype
+  '';
+
+  sha256 = "184vrjkymcm29k1cx00cdvjchzqr1w17925lmh85f0frx7vwljcd";
+
+  meta = {
+    description = "A monospaced Latin font suitable for coding";
+    maintainers = with stdenv.lib.maintainers; [ mt-caret ];
+    platforms = with stdenv.lib.platforms; all;
+    homepage = https://blogs.adobe.com/CCJKType/2015/06/source-han-code-jp.html;
+    license = stdenv.lib.licenses.ofl;
+  };
+}