about summary refs log tree commit diff
path: root/nixos/modules/services/networking/gogoclient.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/gogoclient.nix')
-rw-r--r--nixos/modules/services/networking/gogoclient.nix23
1 files changed, 10 insertions, 13 deletions
diff --git a/nixos/modules/services/networking/gogoclient.nix b/nixos/modules/services/networking/gogoclient.nix
index 07c35e3cb3d6..3b92eb8b06bd 100644
--- a/nixos/modules/services/networking/gogoclient.nix
+++ b/nixos/modules/services/networking/gogoclient.nix
@@ -15,38 +15,35 @@ in
         default = false;
         type =  types.bool;
         description = ''
-          Enable the gogoclient ipv6 tunnel.
+          Enable the gogoCLIENT IPv6 tunnel.
         '';
       };
       autorun = mkOption {
         default = true;
-        description = "
-          Switch to false to create upstart-job and configuration,
-          but not run it automatically
-        ";
+        description = ''
+          Whether to automatically start the tunnel.
+        '';
       };
 
       username = mkOption {
         default = "";
-        description = "
+        description = ''
           Your Gateway6 login name, if any.
-        ";
+        '';
       };
 
       password = mkOption {
         default = "";
         type = types.string;
-        description = "
-          Path to a file (as a string), containing your gogonet password, if any.
-        ";
+        description = ''
+          Path to a file (as a string), containing your gogoNET password, if any.
+        '';
       };
 
       server = mkOption {
         default = "anonymous.freenet6.net";
         example = "broker.freenet6.net";
-        description = "
-          Used Gateway6 server.
-        ";
+        description = "The Gateway6 server to be used.";
       };
     };
   };