about summary refs log tree commit diff
path: root/nixos/modules/services/networking/gogoclient.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-31 13:26:06 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-31 13:26:06 +0100
commitc1159edc65989d6b33aa68e0822ec6e388576b8e (patch)
tree6f15c91b1f24c7a360d1fbd76548bbe1a655d105 /nixos/modules/services/networking/gogoclient.nix
parent456d8ec52b640ff67c88d04c89ea59836953b38f (diff)
downloadnixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.gz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.bz2
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.lz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.xz
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.tar.zst
nixlib-c1159edc65989d6b33aa68e0822ec6e388576b8e.zip
Remove remaining references to Upstart
Diffstat (limited to 'nixos/modules/services/networking/gogoclient.nix')
-rw-r--r--nixos/modules/services/networking/gogoclient.nix23
1 files changed, 10 insertions, 13 deletions
diff --git a/nixos/modules/services/networking/gogoclient.nix b/nixos/modules/services/networking/gogoclient.nix
index 07c35e3cb3d6..3b92eb8b06bd 100644
--- a/nixos/modules/services/networking/gogoclient.nix
+++ b/nixos/modules/services/networking/gogoclient.nix
@@ -15,38 +15,35 @@ in
         default = false;
         type =  types.bool;
         description = ''
-          Enable the gogoclient ipv6 tunnel.
+          Enable the gogoCLIENT IPv6 tunnel.
         '';
       };
       autorun = mkOption {
         default = true;
-        description = "
-          Switch to false to create upstart-job and configuration,
-          but not run it automatically
-        ";
+        description = ''
+          Whether to automatically start the tunnel.
+        '';
       };
 
       username = mkOption {
         default = "";
-        description = "
+        description = ''
           Your Gateway6 login name, if any.
-        ";
+        '';
       };
 
       password = mkOption {
         default = "";
         type = types.string;
-        description = "
-          Path to a file (as a string), containing your gogonet password, if any.
-        ";
+        description = ''
+          Path to a file (as a string), containing your gogoNET password, if any.
+        '';
       };
 
       server = mkOption {
         default = "anonymous.freenet6.net";
         example = "broker.freenet6.net";
-        description = "
-          Used Gateway6 server.
-        ";
+        description = "The Gateway6 server to be used.";
       };
     };
   };