about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2020-04-09 09:46:16 -0400
committerGitHub <noreply@github.com>2020-04-09 09:46:16 -0400
commitd105fbc8c98fc16b14a24ca830fc3e6ac9b01574 (patch)
tree6fd8ce00989a042aef83a96d303de66a0c406744 /pkgs/top-level
parentfb689fc5f2afc9ceb80003e64639977c6a59e4ab (diff)
parent87c7632877199ed1ca2b7c518aead4c59725b157 (diff)
downloadnixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar.gz
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar.bz2
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar.lz
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar.xz
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.tar.zst
nixlib-d105fbc8c98fc16b14a24ca830fc3e6ac9b01574.zip
Merge pull request #84609 from deshaw/contrib/perl-extutilsf77
perlPackages.ExtUtilsF77: init at 1.23
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 07af85d17366..ffd47619a6be 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -6699,6 +6699,20 @@ let
     };
   };
 
+  ExtUtilsF77 = buildPerlPackage rec {
+    pname = "ExtUtils-F77";
+    version = "1.23";
+    src = fetchurl {
+      url = "mirror://cpan/authors/id/K/KG/KGB/${pname}-${version}.tar.gz";
+      sha256 = "634715969c1650be815b3f11c151444e8793ebd6b6d92ce8654d56d6f893a6a9";
+    };
+    buildInputs = [ FileWhich pkgs.gfortran ];
+    meta = {
+      description = "A simple interface to F77 libs";
+      license = with stdenv.lib.licenses; [ artistic1 gpl1Plus ];
+    };
+  };
+
   ExtUtilsHelpers = buildPerlPackage {
     pname = "ExtUtils-Helpers";
     version = "0.026";