about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorxrelkd <46590321+xrelkd@users.noreply.github.com>2020-04-15 15:20:46 +0800
committerxrelkd <46590321+xrelkd@users.noreply.github.com>2020-04-20 20:51:41 +0800
commitb4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa (patch)
tree187f98e129d23311fb0963147617334416743118 /pkgs/tools
parent21861f3a80ef6c599b697e4498228f99e22d6330 (diff)
downloadnixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar.gz
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar.bz2
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar.lz
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar.xz
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.tar.zst
nixlib-b4a2ec0dc67e4af8b489aaacb5d04884bb3fe4fa.zip
sn0int: init at 0.18.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/sn0int/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/tools/security/sn0int/default.nix b/pkgs/tools/security/sn0int/default.nix
new file mode 100644
index 000000000000..9e9cbe2bb3a5
--- /dev/null
+++ b/pkgs/tools/security/sn0int/default.nix
@@ -0,0 +1,32 @@
+{ lib, fetchFromGitHub, rustPlatform,
+  libsodium, libseccomp, sqlite, pkgconfig }:
+
+rustPlatform.buildRustPackage rec {
+  pname = "sn0int";
+  version = "0.18.2";
+
+  src = fetchFromGitHub {
+    owner = "kpcyrd";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0b21b0ryq03zrhqailg2iajirn30l358aj3k44lfnravr4h9zwkj";
+  };
+
+  cargoSha256 = "1pvn0sc325b5fh29m2l6cack4qfssa4lp3zhyb1qzkb3fmw3lgcy";
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [ libsodium libseccomp sqlite ];
+
+  # One of the dependencies (chrootable-https) tries to read "/etc/resolv.conf"
+  # in "checkPhase", hence fails in sandbox of "nix".
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Semi-automatic OSINT framework and package manager";
+    homepage = "https://github.com/kpcyrd/sn0int";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ xrelkd ];
+    platforms = platforms.linux;
+  };
+}