about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-04-18 14:16:40 -0400
committerGitHub <noreply@github.com>2020-04-18 14:16:40 -0400
commit21861f3a80ef6c599b697e4498228f99e22d6330 (patch)
tree100ec691179bff5cd46ca3dac1ed48ec9374255e /pkgs/tools
parent35eb7793a3c110894c44a57d78e4afc9b7e87ef6 (diff)
parent2b87ca0f9ce70c0aac6181288036fabbad7e543c (diff)
downloadnixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar.gz
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar.bz2
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar.lz
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar.xz
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.tar.zst
nixlib-21861f3a80ef6c599b697e4498228f99e22d6330.zip
Merge pull request #85340 from xrelkd/add/sniffglue
sniffglue: init at 0.10.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/sniffglue/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/tools/networking/sniffglue/default.nix b/pkgs/tools/networking/sniffglue/default.nix
new file mode 100644
index 000000000000..83f1e372aa58
--- /dev/null
+++ b/pkgs/tools/networking/sniffglue/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchFromGitHub, rustPlatform, libpcap, libseccomp, pkgconfig }:
+
+rustPlatform.buildRustPackage rec {
+  pname = "sniffglue";
+  version = "0.10.1";
+
+  src = fetchFromGitHub {
+    owner = "kpcyrd";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0vyxlqwh90shihp80fk0plnkjix9i37n2dnypzyz6nx44xd5737s";
+  };
+
+  cargoSha256 = "162p3a696k281cygqpl6gg4makwk2v0g2jnf1gd108dnz4jya11l";
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  buildInputs = [ libpcap libseccomp ];
+
+  meta = with lib; {
+    description = "Secure multithreaded packet sniffer";
+    homepage = "https://github.com/kpcyrd/sniffglue";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ xrelkd ];
+    platforms = platforms.linux;
+  };
+}