about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-10-03 17:12:59 +0200
committerGitHub <noreply@github.com>2016-10-03 17:12:59 +0200
commit69bb34673e9ce4522f6f5f561fb780a7e46b7a7c (patch)
tree5f0686a072ea55c66c3ca39fc5099e4a2eb7cf58 /pkgs/tools
parenta9cd913b7330e64ab0bdfe46b76de187e00623a8 (diff)
parente7ded267bd39f8509c7c4ab2927c6aec9d567540 (diff)
downloadnixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar.gz
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar.bz2
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar.lz
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar.xz
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.tar.zst
nixlib-69bb34673e9ce4522f6f5f561fb780a7e46b7a7c.zip
Merge pull request #19196 from groxxda/xkbbindir
xserver: replace XKB_BINDIR with compile time option
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/bumblebee/default.nix1
-rw-r--r--pkgs/tools/X11/xpra/default.nix2
-rw-r--r--pkgs/tools/X11/xpra/gtk3.nix2
-rw-r--r--pkgs/tools/admin/tigervnc/default.nix1
-rw-r--r--pkgs/tools/misc/xdummy/default.nix1
-rw-r--r--pkgs/tools/misc/xvfb-run/default.nix1
6 files changed, 0 insertions, 8 deletions
diff --git a/pkgs/tools/X11/bumblebee/default.nix b/pkgs/tools/X11/bumblebee/default.nix
index e58aa7042d09..480c929e941a 100644
--- a/pkgs/tools/X11/bumblebee/default.nix
+++ b/pkgs/tools/X11/bumblebee/default.nix
@@ -122,7 +122,6 @@ in stdenv.mkDerivation rec {
 
   postInstall = ''
     wrapProgram "$out/sbin/bumblebeed" \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --prefix PATH : "${bbdPath}" \
       --prefix LD_LIBRARY_PATH : "${bbdLibs}"
 
diff --git a/pkgs/tools/X11/xpra/default.nix b/pkgs/tools/X11/xpra/default.nix
index f3159533931b..9d438dc84b33 100644
--- a/pkgs/tools/X11/xpra/default.nix
+++ b/pkgs/tools/X11/xpra/default.nix
@@ -46,7 +46,6 @@ in buildPythonApplication rec {
 
   postInstall = ''
     wrapProgram $out/bin/xpra \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --set XPRA_LOG_DIR "\$HOME/.xpra" \
       --set XPRA_INSTALL_PREFIX "$out" \
@@ -58,7 +57,6 @@ in buildPythonApplication rec {
 
   #TODO: replace postInstall with postFixup to avoid double wrapping of xpra; needs more work though
   #postFixup = ''
-  #  sed -i '2iexport XKB_BINDIR="${xkbcomp}/bin"' $out/bin/xpra
   #  sed -i '3iexport FONTCONFIG_FILE="${fontsConf}"' $out/bin/xpra
   #  sed -i '4iexport PATH=${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}\${PATH:+:}\$PATH' $out/bin/xpra
   #'';
diff --git a/pkgs/tools/X11/xpra/gtk3.nix b/pkgs/tools/X11/xpra/gtk3.nix
index aece94234a8c..a9ba93507364 100644
--- a/pkgs/tools/X11/xpra/gtk3.nix
+++ b/pkgs/tools/X11/xpra/gtk3.nix
@@ -51,7 +51,6 @@ buildPythonApplication rec {
 
   postInstall = ''
     wrapProgram $out/bin/xpra \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --prefix LD_LIBRARY_PATH : ${libfakeXinerama}/lib \
       --prefix PATH : ${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}
@@ -62,7 +61,6 @@ buildPythonApplication rec {
 
   #TODO: replace postInstall with postFixup to avoid double wrapping of xpra; needs more work though
   #postFixup = ''
-  #  sed -i '2iexport XKB_BINDIR="${xkbcomp}/bin"' $out/bin/xpra
   #  sed -i '3iexport FONTCONFIG_FILE="${fontsConf}"' $out/bin/xpra
   #  sed -i '4iexport PATH=${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}\${PATH:+:}\$PATH' $out/bin/xpra
   #'';
diff --git a/pkgs/tools/admin/tigervnc/default.nix b/pkgs/tools/admin/tigervnc/default.nix
index cac1b9b3c92c..eeefd4d99b5c 100644
--- a/pkgs/tools/admin/tigervnc/default.nix
+++ b/pkgs/tools/admin/tigervnc/default.nix
@@ -20,7 +20,6 @@ stdenv.mkDerivation rec {
 
   patchPhase = ''
     sed -i -e 's,$(includedir)/pixman-1,${if stdenv ? cross then pixman.crossDrv else pixman}/include/pixman-1,' unix/xserver/hw/vnc/Makefile.am
-    sed -i -e '/^$pidFile/a$ENV{XKB_BINDIR}="${if stdenv ? cross then xorg.xkbcomp.crossDrv else xorg.xkbcomp}/bin";' unix/vncserver
     sed -i -e '/^\$cmd \.= " -pn";/a$cmd .= " -xkbdir ${if stdenv ? cross then xkeyboard_config.crossDrv else xkeyboard_config}/etc/X11/xkb";' unix/vncserver
     fontPath=
     for i in $fontDirectories; do
diff --git a/pkgs/tools/misc/xdummy/default.nix b/pkgs/tools/misc/xdummy/default.nix
index 1f4dbc863327..8a411d89da5d 100644
--- a/pkgs/tools/misc/xdummy/default.nix
+++ b/pkgs/tools/misc/xdummy/default.nix
@@ -74,7 +74,6 @@ let
 
 in writeScriptBin "xdummy" ''
   #!${stdenv.shell}
-  export XKB_BINDIR="${xorg.xkbcomp}/bin"
   exec ${xorg.xorgserver.out}/bin/Xorg \
     -noreset \
     -logfile /dev/null \
diff --git a/pkgs/tools/misc/xvfb-run/default.nix b/pkgs/tools/misc/xvfb-run/default.nix
index 838831faaaf8..c33f09529a56 100644
--- a/pkgs/tools/misc/xvfb-run/default.nix
+++ b/pkgs/tools/misc/xvfb-run/default.nix
@@ -16,7 +16,6 @@ stdenv.mkDerivation {
 
     chmod a+x $out/bin/xvfb-run
     wrapProgram $out/bin/xvfb-run \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --prefix PATH : ${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux gawk coreutils ]}
   '';