about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAlexander Ried <ried@mytum.de>2016-10-03 14:28:56 +0200
committerAlexander Ried <ried@mytum.de>2016-10-03 15:03:02 +0200
commite7ded267bd39f8509c7c4ab2927c6aec9d567540 (patch)
tree7b5182443ade183f2b8bc4b6259e007c515e0cfa /pkgs/tools
parent98e2b90cf382e3323f7f5d7b9dcc808099e53685 (diff)
downloadnixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar.gz
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar.bz2
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar.lz
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar.xz
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.tar.zst
nixlib-e7ded267bd39f8509c7c4ab2927c6aec9d567540.zip
xserver: replace XKB_BINDIR with compile time option
---

Using the configure option relieves us of the patch and passing the path
via the env var in many places. Also the env var may not be inherited
when components like gdm spawn new sessions.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/bumblebee/default.nix1
-rw-r--r--pkgs/tools/X11/xpra/default.nix2
-rw-r--r--pkgs/tools/X11/xpra/gtk3.nix2
-rw-r--r--pkgs/tools/admin/tigervnc/default.nix1
-rw-r--r--pkgs/tools/misc/xdummy/default.nix1
-rw-r--r--pkgs/tools/misc/xvfb-run/default.nix1
6 files changed, 0 insertions, 8 deletions
diff --git a/pkgs/tools/X11/bumblebee/default.nix b/pkgs/tools/X11/bumblebee/default.nix
index e58aa7042d09..480c929e941a 100644
--- a/pkgs/tools/X11/bumblebee/default.nix
+++ b/pkgs/tools/X11/bumblebee/default.nix
@@ -122,7 +122,6 @@ in stdenv.mkDerivation rec {
 
   postInstall = ''
     wrapProgram "$out/sbin/bumblebeed" \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --prefix PATH : "${bbdPath}" \
       --prefix LD_LIBRARY_PATH : "${bbdLibs}"
 
diff --git a/pkgs/tools/X11/xpra/default.nix b/pkgs/tools/X11/xpra/default.nix
index f3159533931b..9d438dc84b33 100644
--- a/pkgs/tools/X11/xpra/default.nix
+++ b/pkgs/tools/X11/xpra/default.nix
@@ -46,7 +46,6 @@ in buildPythonApplication rec {
 
   postInstall = ''
     wrapProgram $out/bin/xpra \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --set XPRA_LOG_DIR "\$HOME/.xpra" \
       --set XPRA_INSTALL_PREFIX "$out" \
@@ -58,7 +57,6 @@ in buildPythonApplication rec {
 
   #TODO: replace postInstall with postFixup to avoid double wrapping of xpra; needs more work though
   #postFixup = ''
-  #  sed -i '2iexport XKB_BINDIR="${xkbcomp}/bin"' $out/bin/xpra
   #  sed -i '3iexport FONTCONFIG_FILE="${fontsConf}"' $out/bin/xpra
   #  sed -i '4iexport PATH=${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}\${PATH:+:}\$PATH' $out/bin/xpra
   #'';
diff --git a/pkgs/tools/X11/xpra/gtk3.nix b/pkgs/tools/X11/xpra/gtk3.nix
index aece94234a8c..a9ba93507364 100644
--- a/pkgs/tools/X11/xpra/gtk3.nix
+++ b/pkgs/tools/X11/xpra/gtk3.nix
@@ -51,7 +51,6 @@ buildPythonApplication rec {
 
   postInstall = ''
     wrapProgram $out/bin/xpra \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --prefix LD_LIBRARY_PATH : ${libfakeXinerama}/lib \
       --prefix PATH : ${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}
@@ -62,7 +61,6 @@ buildPythonApplication rec {
 
   #TODO: replace postInstall with postFixup to avoid double wrapping of xpra; needs more work though
   #postFixup = ''
-  #  sed -i '2iexport XKB_BINDIR="${xkbcomp}/bin"' $out/bin/xpra
   #  sed -i '3iexport FONTCONFIG_FILE="${fontsConf}"' $out/bin/xpra
   #  sed -i '4iexport PATH=${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux ]}\${PATH:+:}\$PATH' $out/bin/xpra
   #'';
diff --git a/pkgs/tools/admin/tigervnc/default.nix b/pkgs/tools/admin/tigervnc/default.nix
index cac1b9b3c92c..eeefd4d99b5c 100644
--- a/pkgs/tools/admin/tigervnc/default.nix
+++ b/pkgs/tools/admin/tigervnc/default.nix
@@ -20,7 +20,6 @@ stdenv.mkDerivation rec {
 
   patchPhase = ''
     sed -i -e 's,$(includedir)/pixman-1,${if stdenv ? cross then pixman.crossDrv else pixman}/include/pixman-1,' unix/xserver/hw/vnc/Makefile.am
-    sed -i -e '/^$pidFile/a$ENV{XKB_BINDIR}="${if stdenv ? cross then xorg.xkbcomp.crossDrv else xorg.xkbcomp}/bin";' unix/vncserver
     sed -i -e '/^\$cmd \.= " -pn";/a$cmd .= " -xkbdir ${if stdenv ? cross then xkeyboard_config.crossDrv else xkeyboard_config}/etc/X11/xkb";' unix/vncserver
     fontPath=
     for i in $fontDirectories; do
diff --git a/pkgs/tools/misc/xdummy/default.nix b/pkgs/tools/misc/xdummy/default.nix
index 1f4dbc863327..8a411d89da5d 100644
--- a/pkgs/tools/misc/xdummy/default.nix
+++ b/pkgs/tools/misc/xdummy/default.nix
@@ -74,7 +74,6 @@ let
 
 in writeScriptBin "xdummy" ''
   #!${stdenv.shell}
-  export XKB_BINDIR="${xorg.xkbcomp}/bin"
   exec ${xorg.xorgserver.out}/bin/Xorg \
     -noreset \
     -logfile /dev/null \
diff --git a/pkgs/tools/misc/xvfb-run/default.nix b/pkgs/tools/misc/xvfb-run/default.nix
index 838831faaaf8..c33f09529a56 100644
--- a/pkgs/tools/misc/xvfb-run/default.nix
+++ b/pkgs/tools/misc/xvfb-run/default.nix
@@ -16,7 +16,6 @@ stdenv.mkDerivation {
 
     chmod a+x $out/bin/xvfb-run
     wrapProgram $out/bin/xvfb-run \
-      --set XKB_BINDIR "${xkbcomp}/bin" \
       --set FONTCONFIG_FILE "${fontsConf}" \
       --prefix PATH : ${stdenv.lib.makeBinPath [ getopt xorgserver xauth which utillinux gawk coreutils ]}
   '';