about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-03-11 13:50:12 +0300
committerNikolay Amiantov <ab@fmap.me>2016-03-11 13:50:12 +0300
commit08893956fb4028383964ef0f1271f17564f9328a (patch)
tree3a521917f6cdbe6910c80630a420693b64fa62d2 /pkgs/tools
parentdcfca100ec57b0b8a2af5dbaec7e0a41a76253ac (diff)
parent4ebc7f74f7b80a44218bbc272c4d4b9350efac6b (diff)
downloadnixlib-08893956fb4028383964ef0f1271f17564f9328a.tar
nixlib-08893956fb4028383964ef0f1271f17564f9328a.tar.gz
nixlib-08893956fb4028383964ef0f1271f17564f9328a.tar.bz2
nixlib-08893956fb4028383964ef0f1271f17564f9328a.tar.lz
nixlib-08893956fb4028383964ef0f1271f17564f9328a.tar.xz
nixlib-08893956fb4028383964ef0f1271f17564f9328a.tar.zst
nixlib-08893956fb4028383964ef0f1271f17564f9328a.zip
Merge pull request #13823 from abbradar/colord
colord color management daemon
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/argyllcms/default.nix4
-rw-r--r--pkgs/tools/misc/colord-kde/default.nix3
-rw-r--r--pkgs/tools/misc/colord-kde/fix_check_include_files.patch9
-rw-r--r--pkgs/tools/misc/colord/default.nix7
-rw-r--r--pkgs/tools/misc/xiccd/default.nix24
5 files changed, 42 insertions, 5 deletions
diff --git a/pkgs/tools/graphics/argyllcms/default.nix b/pkgs/tools/graphics/argyllcms/default.nix
index fce383dcc9c4..3c7af45f81dd 100644
--- a/pkgs/tools/graphics/argyllcms/default.nix
+++ b/pkgs/tools/graphics/argyllcms/default.nix
@@ -2,7 +2,7 @@
 , libXrender, libXext, libtiff, libjpeg, libpng, libXScrnSaver, writeText
 , libXdmcp, libXau, lib, openssl, zlib }:
 let
-  version = "1.8.2";
+  version = "1.8.3";
  in
 stdenv.mkDerivation rec {
   name = "argyllcms-${version}";
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
     # Kind of flacky URL, it was reaturning 406 and inconsistent binaries for a
     # while on me. It might be good to find a mirror
     url = "http://www.argyllcms.com/Argyll_V${version}_src.zip";
-    sha256 = "0hnsciwak5chy4a421l8fz7amxzg8kbmy57a07dn460gdg6r63cy";
+    sha256 = "00ggh47qzb3xyl8rnppwxa6j113lr38aiwvsfyxwgs51aqmvq7bd";
 
     # The argyllcms web server doesn't like curl ...
     curlOpts = "--user-agent 'Mozilla/5.0'";
diff --git a/pkgs/tools/misc/colord-kde/default.nix b/pkgs/tools/misc/colord-kde/default.nix
index 606595f46057..52e1845b300f 100644
--- a/pkgs/tools/misc/colord-kde/default.nix
+++ b/pkgs/tools/misc/colord-kde/default.nix
@@ -14,6 +14,9 @@ stdenv.mkDerivation {
 
   buildInputs = [ colord libX11 libXrandr lcms2 kdelibs ];
 
+  patches = [ ./fix_check_include_files.patch ];
+  patchFlags = [ "-p0" ];
+
   enableParallelBuilding = true;
 
   meta = {
diff --git a/pkgs/tools/misc/colord-kde/fix_check_include_files.patch b/pkgs/tools/misc/colord-kde/fix_check_include_files.patch
new file mode 100644
index 000000000000..16d14a6a647a
--- /dev/null
+++ b/pkgs/tools/misc/colord-kde/fix_check_include_files.patch
@@ -0,0 +1,9 @@
+--- CMakeLists.txt.orig	2013-05-01 05:04:34.000000000 +1000

++++ CMakeLists.txt	2015-12-10 20:43:51.351800988 +1100

+@@ -9,6 +9,7 @@

+ include(FindPkgConfig)

+ include(KDE4Defaults)

++include(CheckIncludeFiles)

+ include(ConfigureChecks.cmake)

+ 

+ message(STATUS "X randr is required, found: " ${XRANDR_1_3_FOUND})
\ No newline at end of file
diff --git a/pkgs/tools/misc/colord/default.nix b/pkgs/tools/misc/colord/default.nix
index 3ba5a138e5a7..7e6c3f30784e 100644
--- a/pkgs/tools/misc/colord/default.nix
+++ b/pkgs/tools/misc/colord/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchzip, fetchgit, bashCompletion
 , glib, polkit, pkgconfig, intltool, gusb, libusb1, lcms2, sqlite, systemd, dbus
 , automake, autoconf, libtool, gtk_doc, which, gobjectIntrospection, argyllcms
-, libgudev }:
+, libgudev, sane-backends }:
 
 stdenv.mkDerivation rec {
   name = "colord-1.2.12";
@@ -14,7 +14,8 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   configureFlags = [
-    "--with-udevrulesdir=$out/lib/udev/rules.d"
+    "--enable-sane"
+    "--with-udevrulesdir=$(out)/lib/udev/rules.d"
     "--with-systemdsystemunitdir=$(out)/etc/systemd/system"
     "--localstatedir=/var"
     "--disable-bash-completion"
@@ -27,7 +28,7 @@ stdenv.mkDerivation rec {
   '';
 
   buildInputs = [ glib polkit pkgconfig intltool gusb libusb1 lcms2 sqlite systemd dbus gobjectIntrospection
-                  bashCompletion argyllcms automake autoconf libgudev ];
+                  bashCompletion argyllcms automake autoconf libgudev sane-backends ];
 
   postInstall = ''
     mkdir -p $out/etc/bash_completion.d
diff --git a/pkgs/tools/misc/xiccd/default.nix b/pkgs/tools/misc/xiccd/default.nix
new file mode 100644
index 000000000000..cdc2af195011
--- /dev/null
+++ b/pkgs/tools/misc/xiccd/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, libX11, libXrandr, glib, colord }:
+
+stdenv.mkDerivation rec {
+  name = "xiccd-${version}";
+  version = "0.2.2";
+
+  src = fetchFromGitHub {
+    owner = "agalakhov";
+    repo = "xiccd";
+    rev = "v${version}";
+    sha256 = "17p3vngmmjk52r5p8y41s19nwp7w25bgff68ffd50zdlicd33rsy";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ libX11 libXrandr glib colord ];
+
+  meta = with stdenv.lib; {
+    description = "X color profile daemon";
+    homepage = https://github.com/agalakhov/xiccd;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ abbradar ];
+    platforms = platforms.linux;
+  };
+}