about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2016-03-11 11:05:21 +0100
committerLuca Bruno <lucabru@src.gnome.org>2016-03-11 11:05:21 +0100
commitdcfca100ec57b0b8a2af5dbaec7e0a41a76253ac (patch)
tree49c0e1155893a4f9f034e93f16459765a2b46a82 /pkgs/tools
parent9f578af6898f3579610abffb4b571767e555c7f6 (diff)
parent8e604f7937e9bfd729af13fa8022fa88218a65c0 (diff)
downloadnixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar.gz
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar.bz2
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar.lz
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar.xz
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.tar.zst
nixlib-dcfca100ec57b0b8a2af5dbaec7e0a41a76253ac.zip
Merge pull request #12525 from knupfer/ngx_brotli
add nginxModules.brotli
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/compression/brotli/unstable.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/pkgs/tools/compression/brotli/unstable.nix b/pkgs/tools/compression/brotli/unstable.nix
new file mode 100644
index 000000000000..59eb1e1d469a
--- /dev/null
+++ b/pkgs/tools/compression/brotli/unstable.nix
@@ -0,0 +1,46 @@
+{ stdenv, fetchFromGitHub }:
+
+# ?TODO: there's also python lib in there
+
+stdenv.mkDerivation rec {
+  name = "brotli-20160112";
+  version = "bed93862";
+
+  src = fetchFromGitHub {
+    owner = "google";
+    repo = "brotli";
+    rev = "bed93862608d4d232ebe6d229f04e48399775e8b";
+    sha256 = "0g94kqh984qkbqbj4fpkkyji9wnbrb9cs32r9d6niw1sqfnfkd6f";
+  };
+
+  preConfigure = "cd tools";
+
+  # Debian installs "brotli" instead of "bro" but let's keep upstream choice for now.
+  installPhase = ''
+    mkdir -p "$out/bin"
+    mv ./bro "$out/bin/"
+  '';
+
+  meta = with stdenv.lib; {
+    inherit (src.meta) homepage;
+
+    description = "A generic-purpose lossless compression algorithm and tool";
+
+    longDescription =
+      ''  Brotli is a generic-purpose lossless compression algorithm that
+          compresses data using a combination of a modern variant of the LZ77
+          algorithm, Huffman coding and 2nd order context modeling, with a
+          compression ratio comparable to the best currently available
+          general-purpose compression methods. It is similar in speed with
+          deflate but offers more dense compression.
+
+          The specification of the Brotli Compressed Data Format is defined
+          in the following internet draft:
+          http://www.ietf.org/id/draft-alakuijala-brotli
+      '';
+
+    license = licenses.mit;
+    maintainers = [];
+    platforms = platforms.all;
+  };
+}