about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-10-01 10:43:44 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-10-01 10:43:44 -0700
commit98172435f7ccf1912ab7804296c5026a545ae2dd (patch)
tree8df4430c1dbb2a5a09ca5085cd9198da896c4a87 /pkgs/servers
parente7bb9e102323f79832c2e0553b98651a582368c9 (diff)
parent14961c87810330d22fc1ee11e11a17e32805ff8b (diff)
downloadnixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar.gz
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar.bz2
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar.lz
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar.xz
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.tar.zst
nixlib-98172435f7ccf1912ab7804296c5026a545ae2dd.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/jetty/default.nix6
-rw-r--r--pkgs/servers/neard/default.nix3
-rw-r--r--pkgs/servers/xmpp/openfire/default.nix2
3 files changed, 6 insertions, 5 deletions
diff --git a/pkgs/servers/http/jetty/default.nix b/pkgs/servers/http/jetty/default.nix
index f691f362bb24..78b6e4cc7eee 100644
--- a/pkgs/servers/http/jetty/default.nix
+++ b/pkgs/servers/http/jetty/default.nix
@@ -1,13 +1,13 @@
 {stdenv, fetchurl, unzip}:
 
 stdenv.mkDerivation {
-  name = "jetty-5.1.4";
+  name = "jetty-6.1.4";
 
   builder = ./bin-builder.sh;
   buildInputs = [unzip];
 
   src = fetchurl {
-    url = mirror://sourceforge/jetty/jetty-5.1.4.zip;
-    sha256 = "1lzvsrlybrf3zzzv4hi2v82qzpkfkib3xbwwlya8c08gf0360mrk";
+    url = mirror://sourceforge/jetty/jetty-6.1.4.zip;
+    sha256 = "061cx442g5a5szzms9zhnfmr4aipmqyy9r8m5r84gr79gz9z6dv0";
   };
 }
diff --git a/pkgs/servers/neard/default.nix b/pkgs/servers/neard/default.nix
index a76f10a262db..995ffc41c60e 100644
--- a/pkgs/servers/neard/default.nix
+++ b/pkgs/servers/neard/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ autoreconfHook pkgconfig systemd glib dbus libnl pythonPackages.python pythonPackages.wrapPython ];
   pythonPath = [ pythonPackages.pygobject pythonPackages.dbus pythonPackages.pygtk ];
 
-  configureFlags = [ "--disable-debug" "--enable-tools" "--with-systemdsystemunitdir=$out/lib/systemd/system" ];
+  configureFlags = [ "--disable-debug" "--enable-tools" "--enable-ese" "--with-systemdsystemunitdir=$out/lib/systemd/system" ];
 
   postInstall = ''
     install -m 0755 tools/snep-send $out/bin/
@@ -19,6 +19,7 @@ stdenv.mkDerivation rec {
     install -D -m644 src/neard.service $out/lib/systemd/system/neard.service
     install -D -m644 src/main.conf $out/etc/neard/main.conf
 
+    # INFO: the config option "--enable-test" would copy the apps to $out/lib/neard/test/ instead
     install -d $out/lib/neard
     install -m 0755 test/* $out/lib/neard/
     wrapPythonProgramsIn $out/lib/neard "$out $pythonPath"
diff --git a/pkgs/servers/xmpp/openfire/default.nix b/pkgs/servers/xmpp/openfire/default.nix
index 3fb89d7a222b..53924f9888c0 100644
--- a/pkgs/servers/xmpp/openfire/default.nix
+++ b/pkgs/servers/xmpp/openfire/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ jre ];
 
   installPhase = ''
-    sed -e 's@\(common_jvm_locations\)=.*@\1${jre}@' -i bin/openfire
+    sed -e 's@\(common_jvm_locations=\).*@\1${jre}@' -i bin/openfire
     cp -r . $out
     rm -r $out/logs
     mv $out/conf $out/conf.inst