about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-09-30 13:26:04 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-09-30 13:26:04 -0700
commite7bb9e102323f79832c2e0553b98651a582368c9 (patch)
tree029f5217f94e4a0d1f082fb19b90d5b8a00ca6ee /pkgs/servers
parentd14bb302a7de75ec91e48e1efb4ed5c123c96e3b (diff)
parent647671bc537d35923fdaa6f7c03385868635d615 (diff)
downloadnixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar.gz
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar.bz2
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar.lz
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar.xz
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.tar.zst
nixlib-e7bb9e102323f79832c2e0553b98651a582368c9.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/neard/default.nix11
-rw-r--r--pkgs/servers/p910nd/default.nix48
2 files changed, 57 insertions, 2 deletions
diff --git a/pkgs/servers/neard/default.nix b/pkgs/servers/neard/default.nix
index 948da3b02251..a76f10a262db 100644
--- a/pkgs/servers/neard/default.nix
+++ b/pkgs/servers/neard/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, autoreconfHook, pkgconfig, systemd, glib, dbus, libnl }:
+{ stdenv, fetchgit, autoreconfHook, pkgconfig, systemd, glib, dbus, libnl, pythonPackages }:
 
 stdenv.mkDerivation rec {
   name = "neard-0.15-post-git-20510929";
@@ -8,13 +8,20 @@ stdenv.mkDerivation rec {
     sha256 = "08327b536ad8460a08bdceeec48c561e75ca56e5e0ee034c40d02cd1545906c0";
   };
 
-  buildInputs = [ autoreconfHook pkgconfig systemd glib dbus libnl ];
+  buildInputs = [ autoreconfHook pkgconfig systemd glib dbus libnl pythonPackages.python pythonPackages.wrapPython ];
+  pythonPath = [ pythonPackages.pygobject pythonPackages.dbus pythonPackages.pygtk ];
 
   configureFlags = [ "--disable-debug" "--enable-tools" "--with-systemdsystemunitdir=$out/lib/systemd/system" ];
 
   postInstall = ''
+    install -m 0755 tools/snep-send $out/bin/
+
     install -D -m644 src/neard.service $out/lib/systemd/system/neard.service
     install -D -m644 src/main.conf $out/etc/neard/main.conf
+
+    install -d $out/lib/neard
+    install -m 0755 test/* $out/lib/neard/
+    wrapPythonProgramsIn $out/lib/neard "$out $pythonPath"
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/servers/p910nd/default.nix b/pkgs/servers/p910nd/default.nix
new file mode 100644
index 000000000000..ea5214c7bb44
--- /dev/null
+++ b/pkgs/servers/p910nd/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchurl }:
+
+let
+  version = "0.97";
+  name = "p910nd-${version}";
+in stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchurl {
+    sha256 = "0vy2qf386dif1nqznmy3j953mq7c4lk6j2hgyzkbmfi4msiq1jaa";
+    url = "mirror://sourceforge/p910nd/${name}.tar.bz2";
+  };
+
+  postPatch = ''
+    sed -e "s|/usr||g" -i Makefile
+  '';
+
+  makeFlags = "DESTDIR=$(out) BINDIR=/bin";
+
+  postInstall = ''
+    # Match the man page:
+    mv $out/etc/init.d/p910nd{,.sh}
+
+    # The legacy init script is useful only (and even then...) as an example:
+    mkdir -p $out/share/doc/examples
+    mv $out/etc $out/share/doc/examples
+  '';
+
+  meta = with stdenv.lib; {
+    inherit version;
+    description = "Small printer daemon passing jobs directly to the printer";
+    longDescription = ''
+      p910nd is a small printer daemon intended for diskless platforms that
+      does not spool to disk but passes the job directly to the printer.
+      Normally a lpr daemon on a spooling host connects to it with a TCP
+      connection on port 910n (where n=0, 1, or 2 for lp0, 1 and 2
+      respectively). p910nd is particularly useful for diskless platforms.
+      Common Unix Printing System (CUPS) supports this protocol, it's called
+      the AppSocket protocol and has the scheme socket://. LPRng also supports
+      this protocol and the syntax is lp=remotehost%9100 in /etc/printcap.
+    '';
+    homepage = http://p910nd.sourceforge.net/;
+    downloadPage = http://sourceforge.net/projects/p910nd/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ nckx ];
+  };
+}