about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:38:34 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:38:34 -0700
commit6775c0696f9e8b2c148f9be382f30bce7a4ec4a0 (patch)
tree65075aa36e5c89efc1dd64d88cbeae6cd42b84e1 /pkgs/servers
parent5486c08dc27c5cdc7b251adf6d50d306501ba3b1 (diff)
downloadnixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar.gz
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar.bz2
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar.lz
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar.xz
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.tar.zst
nixlib-6775c0696f9e8b2c148f9be382f30bce7a4ec4a0.zip
postgresql: 9.4.1 -> 9.4.2
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/9.4.x.nix47
-rw-r--r--pkgs/servers/sql/postgresql/generic.nix8
2 files changed, 13 insertions, 42 deletions
diff --git a/pkgs/servers/sql/postgresql/9.4.x.nix b/pkgs/servers/sql/postgresql/9.4.x.nix
index 73f416912a2a..0d8b573dcc56 100644
--- a/pkgs/servers/sql/postgresql/9.4.x.nix
+++ b/pkgs/servers/sql/postgresql/9.4.x.nix
@@ -1,44 +1,11 @@
-{ stdenv, fetchurl, zlib, readline, libossp_uuid, openssl }:
+{ callPackage, fetchurl, ... } @ args:
 
-with stdenv.lib;
-
-let version = "9.4.1"; in
-
-stdenv.mkDerivation rec {
-  name = "postgresql-${version}";
+callPackage ./generic.nix (args // rec {
+  psqlSchema = "9.4";
+  version = "${psqlSchema}.2";
 
   src = fetchurl {
-    url = "mirror://postgresql/source/v${version}/${name}.tar.bz2";
-    sha256 = "19n3i14bhmw8dacd2kl3n1wzj362qv3fjmal5vsvi580h9ybgp99";
-  };
-
-  buildInputs = [ zlib readline openssl ]
-                ++ optionals (!stdenv.isDarwin) [ libossp_uuid ];
-
-  enableParallelBuilding = true;
-
-  makeFlags = [ "world" ];
-
-  configureFlags = [ "--with-openssl" ]
-                   ++ optional (!stdenv.isDarwin) "--with-ossp-uuid";
-
-  patches = [ ./disable-resolve_symlinks-94.patch ./less-is-more.patch ];
-
-  installTargets = [ "install-world" ];
-
-  LC_ALL = "C";
-
-  passthru = {
-    inherit readline;
-    psqlSchema = "9.4";
-  };
-
-  meta = with stdenv.lib; {
-    homepage = http://www.postgresql.org/;
-    description = "A powerful, open source object-relational database system";
-    license = licenses.postgresql;
-    maintainers = with maintaiers; [ ocharles ];
-    platforms = platforms.unix;
-    hydraPlatforms = platforms.linux;
+    url = "mirror://postgresql/source/v${version}/postgresql-${version}.tar.bz2";
+    sha256 = "04adpfg2f7ip96rh3jjygx5cpgasrrp1dl2wswjivfk5q68s3zc1";
   };
-}
+})
diff --git a/pkgs/servers/sql/postgresql/generic.nix b/pkgs/servers/sql/postgresql/generic.nix
index 88e2b77cf83c..f8d1ad0a4754 100644
--- a/pkgs/servers/sql/postgresql/generic.nix
+++ b/pkgs/servers/sql/postgresql/generic.nix
@@ -69,14 +69,12 @@ stdenv.mkDerivation rec {
     (mkWith   false                     "perl"              null)  # Maybe enable some day
     (mkWith   false                     "python"            null)  # Maybe enable some day
     (mkWith   (optKerberos != null)     "gssapi"            null)
-    (mkWith   false                     "krb5"              null)
     (mkWith   (optPam != null)          "pam"               null)
     (mkWith   (optOpenldap != null)     "ldap"              null)
     (mkWith   false                     "bonjour"           null)
     (mkWith   (optOpenssl != null)      "openssl"           null)
     (mkWith   (optReadline != null)     "readline"          null)
     (mkWith   false                     "libedit-preferred" null)
-    (mkWith   (optLibossp_uuid != null) "ossp-uuid"         null)
     (mkWith   (optLibxml2 != null)      "libxml"            null)
     (mkWith   (optLibxslt != null)      "libxslt"           null)
     (mkWith   (optZlib != null)         "zlib"              null)
@@ -84,6 +82,12 @@ stdenv.mkDerivation rec {
     (mkWith   false                     "selinux"           null)
   ] ++ optionals (versionOlder version "9.3.0") [
     (mkEnable true                      "shared"            null)
+  ] ++ optionals (versionAtLeast version "9.4.0") [
+    (mkEnable false                     "tap-tests"         null)
+    (mkWith   (optLibossp_uuid != null) "uuid"              "ossp")
+  ] ++ optionals (versionOlder version "9.4.0") [
+    (mkWith   false                     "krb5"              null)
+    (mkWith   (optLibossp_uuid != null) "ossp-uuid"         null)
   ];
 
   enableParallelBuilding = true;