about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:34:28 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-05-23 19:34:28 -0700
commit5486c08dc27c5cdc7b251adf6d50d306501ba3b1 (patch)
treef268f9e394575ba2c974c9ce509726ff5adb822e /pkgs/servers
parent7174391e5bff8206025d4c7c7107d11487c534f7 (diff)
downloadnixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar.gz
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar.bz2
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar.lz
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar.xz
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.tar.zst
nixlib-5486c08dc27c5cdc7b251adf6d50d306501ba3b1.zip
postgresql: 9.3.6 -> 9.3.7
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/9.3.x.nix47
-rw-r--r--pkgs/servers/sql/postgresql/generic.nix3
2 files changed, 9 insertions, 41 deletions
diff --git a/pkgs/servers/sql/postgresql/9.3.x.nix b/pkgs/servers/sql/postgresql/9.3.x.nix
index 4406aecaa897..9671c316832d 100644
--- a/pkgs/servers/sql/postgresql/9.3.x.nix
+++ b/pkgs/servers/sql/postgresql/9.3.x.nix
@@ -1,44 +1,11 @@
-{ stdenv, fetchurl, zlib, readline, libossp_uuid, openssl}:
+{ callPackage, fetchurl, ... } @ args:
 
-with stdenv.lib;
-
-let version = "9.3.6"; in
-
-stdenv.mkDerivation rec {
-  name = "postgresql-${version}";
+callPackage ./generic.nix (args // rec {
+  psqlSchema = "9.3";
+  version = "${psqlSchema}.7";
 
   src = fetchurl {
-    url = "mirror://postgresql/source/v${version}/${name}.tar.bz2";
-    sha256 = "056ass7nnfyv7blv02anv795kgpz77gipdpxggd835cdwrhwns13";
-  };
-
-  buildInputs = [ zlib readline openssl ]
-                ++ optionals (!stdenv.isDarwin) [ libossp_uuid ];
-
-  enableParallelBuilding = true;
-
-  makeFlags = [ "world" ];
-
-  configureFlags = [ "--with-openssl" ]
-                   ++ optional (!stdenv.isDarwin) "--with-ossp-uuid";
-
-  patches = [ ./disable-resolve_symlinks.patch ./less-is-more.patch ];
-
-  installTargets = [ "install-world" ];
-
-  LC_ALL = "C";
-
-  passthru = {
-    inherit readline;
-    psqlSchema = "9.3";
-  };
-
-  meta = with stdenv.lib; {
-    homepage = http://www.postgresql.org/;
-    description = "A powerful, open source object-relational database system";
-    license = licenses.postgresql;
-    maintainers = with maintaiers; [ ocharles ];
-    platforms = platforms.unix;
-    hydraPlatforms = platforms.linux;
+    url = "mirror://postgresql/source/v${version}/postgresql-${version}.tar.bz2";
+    sha256 = "09iqr9sldiq7jz1rdnywp2wv36lxy5m8kch3vpchd1s4fz75c7aw";
   };
-}
+})
diff --git a/pkgs/servers/sql/postgresql/generic.nix b/pkgs/servers/sql/postgresql/generic.nix
index 46d2030224d8..88e2b77cf83c 100644
--- a/pkgs/servers/sql/postgresql/generic.nix
+++ b/pkgs/servers/sql/postgresql/generic.nix
@@ -52,7 +52,6 @@ stdenv.mkDerivation rec {
     (mkEnable true                      "integer-datetimes" null)
     (mkEnable true                      "nls"               null)
     (mkWith   true                      "pgport"            "5432")
-    (mkEnable true                      "shared"            null)
     (mkEnable true                      "rpath"             null)
     (mkEnable true                      "spinlocks"         null)
     (mkEnable false                     "debug"             null)
@@ -83,6 +82,8 @@ stdenv.mkDerivation rec {
     (mkWith   (optZlib != null)         "zlib"              null)
   ] ++ optionals (versionAtLeast version "9.1.0") [
     (mkWith   false                     "selinux"           null)
+  ] ++ optionals (versionOlder version "9.3.0") [
+    (mkEnable true                      "shared"            null)
   ];
 
   enableParallelBuilding = true;