about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMartin Weinelt <mweinelt@users.noreply.github.com>2021-02-11 19:40:44 +0100
committerGitHub <noreply@github.com>2021-02-11 19:40:44 +0100
commit01d2239359dab3e4e48657498e4e38ecacad335d (patch)
treee82920c0c1c594b5828398dcee11fde294ba2d6c /pkgs/servers
parent2f48b74bf73704dd23b4ca1a6ace15bd9883eb0a (diff)
parentdf1b15ce54fd2d047b5330ded0e923d156ab78f2 (diff)
downloadnixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar.gz
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar.bz2
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar.lz
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar.xz
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.tar.zst
nixlib-01d2239359dab3e4e48657498e4e38ecacad335d.zip
Merge pull request #112772 from mweinelt/home-assistant
home-assistant: 2021.2.2 -> 2021.2.3
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/home-assistant/component-packages.nix2
-rw-r--r--pkgs/servers/home-assistant/default.nix13
2 files changed, 6 insertions, 9 deletions
diff --git a/pkgs/servers/home-assistant/component-packages.nix b/pkgs/servers/home-assistant/component-packages.nix
index 2f97cb4a9684..d8bca0f55179 100644
--- a/pkgs/servers/home-assistant/component-packages.nix
+++ b/pkgs/servers/home-assistant/component-packages.nix
@@ -2,7 +2,7 @@
 # Do not edit!
 
 {
-  version = "2021.2.2";
+  version = "2021.2.3";
   components = {
     "abode" = ps: with ps; [ abodepy ];
     "accuweather" = ps: with ps; [ accuweather ];
diff --git a/pkgs/servers/home-assistant/default.nix b/pkgs/servers/home-assistant/default.nix
index bb697d1035ad..fae857fda5dc 100644
--- a/pkgs/servers/home-assistant/default.nix
+++ b/pkgs/servers/home-assistant/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, nixosTests, lib, fetchurl, fetchFromGitHub, fetchpatch, python3, protobuf3_6
+{ stdenv, nixosTests, lib, fetchFromGitHub, python3
 
 # Look up dependencies of specified components in component-packages.nix
 , extraComponents ? [ ]
@@ -57,7 +57,7 @@ let
   extraBuildInputs = extraPackages py.pkgs;
 
   # Don't forget to run parse-requirements.py after updating
-  hassVersion = "2021.2.2";
+  hassVersion = "2021.2.3";
 
 in with py.pkgs; buildPythonApplication rec {
   pname = "homeassistant";
@@ -76,7 +76,7 @@ in with py.pkgs; buildPythonApplication rec {
     owner = "home-assistant";
     repo = "core";
     rev = version;
-    sha256 = "0y7yj3kwk2454yghslvv5s2783rch9pznhxrw4mh3plr6qzi70rp";
+    sha256 = "0s1jcd94wwvmvzq86w8s9dwfvnmjs9l661z9pc6kwgagggjjgd8c";
   };
 
   # leave this in, so users don't have to constantly update their downstream patch handling
@@ -181,7 +181,8 @@ in with py.pkgs; buildPythonApplication rec {
   ];
 
   pytestFlagsArray = [
-    "-n auto"
+    # limit amout of runners to reduce race conditions
+    "-n 2"
     # assign tests grouped by file to workers
     "--dist loadfile"
     # don't bulk test all components
@@ -199,10 +200,6 @@ in with py.pkgs; buildPythonApplication rec {
     # keyring.errors.NoKeyringError: No recommended backend was available.
     "test_secrets_from_unrelated_fails"
     "test_secrets_credstash"
-    # system_log/test_init.py: assert 0 == 1 where 0 = len([])
-    "test_error_posted_as_event"
-    # ssdp/test_init.py: RuntimeError: Event loop is closed
-    "test_scan_match_st"
   ];
 
   preCheck = ''