about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2021-02-11 16:01:01 +0100
committerMartin Weinelt <hexa@darmstadt.ccc.de>2021-02-11 18:12:23 +0100
commitdf1b15ce54fd2d047b5330ded0e923d156ab78f2 (patch)
tree6a57f3b3995c9d77957246b4a5bd4a5af2fce3f7 /pkgs/servers
parent84972d805f410120600dd6cccb1c6c2764f8cd2e (diff)
downloadnixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar.gz
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar.bz2
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar.lz
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar.xz
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.tar.zst
nixlib-df1b15ce54fd2d047b5330ded0e923d156ab78f2.zip
home-assistant: reduce to two xdist job runners
This more closely replicates home-assistants upstream test environment
which runs on GitHub Actions, which according to its specifications¹
provides a 2-core CPU and `-n auto` would scale with the locally
available thread count.

This is another possible reason for the amount of race conditions
(`RuntimeError: Event loop is closed`) we were seeing, since moving to
parallel testing using xdist.

Reenable a few tests, that are likely to be caused by those race
conditions.

[1] https://docs.github.com/en/actions/reference/specifications-for-github-hosted-runners
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/home-assistant/default.nix11
1 files changed, 2 insertions, 9 deletions
diff --git a/pkgs/servers/home-assistant/default.nix b/pkgs/servers/home-assistant/default.nix
index ae4f402947b5..fae857fda5dc 100644
--- a/pkgs/servers/home-assistant/default.nix
+++ b/pkgs/servers/home-assistant/default.nix
@@ -181,7 +181,8 @@ in with py.pkgs; buildPythonApplication rec {
   ];
 
   pytestFlagsArray = [
-    "-n auto"
+    # limit amout of runners to reduce race conditions
+    "-n 2"
     # assign tests grouped by file to workers
     "--dist loadfile"
     # don't bulk test all components
@@ -199,14 +200,6 @@ in with py.pkgs; buildPythonApplication rec {
     # keyring.errors.NoKeyringError: No recommended backend was available.
     "test_secrets_from_unrelated_fails"
     "test_secrets_credstash"
-    # system_log/test_init.py: assert 0 == 1 where 0 = len([])
-    "test_error_posted_as_event"
-    # ssdp/test_init.py: RuntimeError: Event loop is closed
-    "test_scan_match_st"
-    # sun/test_init.py: RuntimeError: Event loop is closed
-    "test_setting_rising"
-    # sun/test_trigger.py: RuntimeError Event loop is closed
-    "test_sunset_trigger"
   ];
 
   preCheck = ''