about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2024-02-14 20:09:56 -0500
committerGitHub <noreply@github.com>2024-02-14 20:09:56 -0500
commitafb9a45824f77c0b2290807d5717d38463c148c7 (patch)
tree8a48f2ccc44edc58d14a074f7a05e023567d7445 /pkgs/os-specific
parentf92811016c9b0bb87f180530257c568d68a76861 (diff)
parent73201199902cc15e011f62c2eb7c19c960264812 (diff)
downloadnixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar.gz
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar.bz2
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar.lz
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar.xz
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.tar.zst
nixlib-afb9a45824f77c0b2290807d5717d38463c148c7.zip
Merge pull request #287053 from trofi/ocf-resource-agents-fix-autoconf-2.72-build
ocf-resource-agents: fix build against `autoconf-2.72`
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/ocf-resource-agents/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/ocf-resource-agents/default.nix b/pkgs/os-specific/linux/ocf-resource-agents/default.nix
index 11f094f72c9d..0e6377452670 100644
--- a/pkgs/os-specific/linux/ocf-resource-agents/default.nix
+++ b/pkgs/os-specific/linux/ocf-resource-agents/default.nix
@@ -5,6 +5,7 @@
 , runCommand
 , lndir
 , fetchFromGitHub
+, fetchpatch
 , autoreconfHook
 , pkg-config
 , python3
@@ -32,6 +33,16 @@ let
       sha256 = "0haryi3yrszdfpqnkfnppxj1yiy6ipah6m80snvayc7v0ss0wnir";
     };
 
+    patches = [
+      # autoconf-2.72 upstream fix:
+      #   https://github.com/ClusterLabs/resource-agents/pull/1908
+      (fetchpatch {
+        name = "autoconf-2.72.patch";
+        url = "https://github.com/ClusterLabs/resource-agents/commit/bac658711a61fd704e792e2a0a45a2137213c442.patch";
+        hash = "sha256-Xq7W8pMRmFZmkqb2430bY5zdmVTrUrob6GwGiN6/bKY=";
+      })
+    ];
+
     nativeBuildInputs = [
       autoreconfHook
       pkg-config