about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorSergei Trofimovich <slyich@gmail.com>2024-02-07 19:36:22 +0000
committerSergei Trofimovich <slyich@gmail.com>2024-02-07 19:37:34 +0000
commit73201199902cc15e011f62c2eb7c19c960264812 (patch)
tree606b6f42ed50aba8c5032bb5fb614ef4b432fd29 /pkgs/os-specific
parent7f90b56ea122222d295971aee3c95d9f48ee38fe (diff)
downloadnixlib-73201199902cc15e011f62c2eb7c19c960264812.tar
nixlib-73201199902cc15e011f62c2eb7c19c960264812.tar.gz
nixlib-73201199902cc15e011f62c2eb7c19c960264812.tar.bz2
nixlib-73201199902cc15e011f62c2eb7c19c960264812.tar.lz
nixlib-73201199902cc15e011f62c2eb7c19c960264812.tar.xz
nixlib-73201199902cc15e011f62c2eb7c19c960264812.tar.zst
nixlib-73201199902cc15e011f62c2eb7c19c960264812.zip
ocf-resource-agents: fix build against `autoconf-2.72`
Without the change build fails in` master` as https://hydra.nixos.org/build/247269225:

    checking whether gcc supports "-Wunsigned-char"... checking how to run the C preprocessor... gcc -E
    configure: error: in '/build/source':
    configure: error: C preprocessor "gcc -E" fails sanity check
    See 'config.log' for more details
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/ocf-resource-agents/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/ocf-resource-agents/default.nix b/pkgs/os-specific/linux/ocf-resource-agents/default.nix
index 11f094f72c9d..0e6377452670 100644
--- a/pkgs/os-specific/linux/ocf-resource-agents/default.nix
+++ b/pkgs/os-specific/linux/ocf-resource-agents/default.nix
@@ -5,6 +5,7 @@
 , runCommand
 , lndir
 , fetchFromGitHub
+, fetchpatch
 , autoreconfHook
 , pkg-config
 , python3
@@ -32,6 +33,16 @@ let
       sha256 = "0haryi3yrszdfpqnkfnppxj1yiy6ipah6m80snvayc7v0ss0wnir";
     };
 
+    patches = [
+      # autoconf-2.72 upstream fix:
+      #   https://github.com/ClusterLabs/resource-agents/pull/1908
+      (fetchpatch {
+        name = "autoconf-2.72.patch";
+        url = "https://github.com/ClusterLabs/resource-agents/commit/bac658711a61fd704e792e2a0a45a2137213c442.patch";
+        hash = "sha256-Xq7W8pMRmFZmkqb2430bY5zdmVTrUrob6GwGiN6/bKY=";
+      })
+    ];
+
     nativeBuildInputs = [
       autoreconfHook
       pkg-config