about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2022-11-28 02:13:36 +0100
committerGitHub <noreply@github.com>2022-11-28 02:13:36 +0100
commit4724d88a820aa21c2f9ea1ff4b8db5971f077436 (patch)
tree84f18c5c0f93b9df7f70eaadc4519177eac3af6b /pkgs/os-specific
parentbe9e3762e719211368d186f547f847737baad720 (diff)
parent6a93ccb6ef24e612d4ba7e4026aa81778e0d7375 (diff)
downloadnixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar.gz
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar.bz2
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar.lz
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar.xz
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.tar.zst
nixlib-4724d88a820aa21c2f9ea1ff4b8db5971f077436.zip
Merge pull request #202950 from SuperSandro2000/intel-compute-runtime
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/intel-compute-runtime/default.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/pkgs/os-specific/linux/intel-compute-runtime/default.nix b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
index 177a9d58e2d4..8ea51a1ebdb0 100644
--- a/pkgs/os-specific/linux/intel-compute-runtime/default.nix
+++ b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
@@ -1,9 +1,9 @@
-{ lib, stdenv
+{ lib
+, stdenv
 , fetchFromGitHub
 , patchelf
 , cmake
 , pkg-config
-
 , intel-gmmlib
 , intel-graphics-compiler
 , libva
@@ -11,13 +11,13 @@
 
 stdenv.mkDerivation rec {
   pname = "intel-compute-runtime";
-  version = "22.35.24055";
+  version = "22.43.24558";
 
   src = fetchFromGitHub {
     owner = "intel";
     repo = "compute-runtime";
     rev = version;
-    sha256 = "sha256-MOWlhzhEGYyHGk6N+H7O2BLho4YFyvcCbj/zafhzLEw=";
+    sha256 = "sha256-/hiDJLtEOLbnFjT697yLie5E7819fZM3xricPwe4xN0=";
   };
 
   nativeBuildInputs = [ cmake pkg-config ];
@@ -26,10 +26,8 @@ stdenv.mkDerivation rec {
 
   cmakeFlags = [
     "-DSKIP_UNIT_TESTS=1"
-
     "-DIGC_DIR=${intel-graphics-compiler}"
     "-DOCL_ICD_VENDORDIR=${placeholder "out"}/etc/OpenCL/vendors"
-
     # The install script assumes this path is relative to CMAKE_INSTALL_PREFIX
     "-DCMAKE_INSTALL_LIBDIR=lib"
   ];
@@ -45,10 +43,10 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with lib; {
-    homepage    = "https://github.com/intel/compute-runtime";
+    homepage = "https://github.com/intel/compute-runtime";
     description = "Intel Graphics Compute Runtime for OpenCL. Replaces Beignet for Gen8 (Broadwell) and beyond";
-    license     = licenses.mit;
-    platforms   = platforms.linux;
-    maintainers = with maintainers; [ gloaming ];
+    license = licenses.mit;
+    platforms = [ "x86_64-linux" "aarch64-linux" ];
+    maintainers = with maintainers; [ SuperSandro2000 ];
   };
 }