about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@sap.com>2022-11-26 01:53:31 +0100
committerSandro Jäckel <sandro.jaeckel@sap.com>2022-11-26 01:55:57 +0100
commit6a93ccb6ef24e612d4ba7e4026aa81778e0d7375 (patch)
treeb531c90b1f958074fb0022b34eac87eca0afe127 /pkgs/os-specific
parent32802abcfd5de6ba3bd099b2e3fcd3f6b819c617 (diff)
downloadnixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar.gz
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar.bz2
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar.lz
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar.xz
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.tar.zst
nixlib-6a93ccb6ef24e612d4ba7e4026aa81778e0d7375.zip
intel-compute-runtime: 22.35.24055 -> 22.43.24558, adopt, cleanup
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/intel-compute-runtime/default.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/pkgs/os-specific/linux/intel-compute-runtime/default.nix b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
index 177a9d58e2d4..8ea51a1ebdb0 100644
--- a/pkgs/os-specific/linux/intel-compute-runtime/default.nix
+++ b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
@@ -1,9 +1,9 @@
-{ lib, stdenv
+{ lib
+, stdenv
 , fetchFromGitHub
 , patchelf
 , cmake
 , pkg-config
-
 , intel-gmmlib
 , intel-graphics-compiler
 , libva
@@ -11,13 +11,13 @@
 
 stdenv.mkDerivation rec {
   pname = "intel-compute-runtime";
-  version = "22.35.24055";
+  version = "22.43.24558";
 
   src = fetchFromGitHub {
     owner = "intel";
     repo = "compute-runtime";
     rev = version;
-    sha256 = "sha256-MOWlhzhEGYyHGk6N+H7O2BLho4YFyvcCbj/zafhzLEw=";
+    sha256 = "sha256-/hiDJLtEOLbnFjT697yLie5E7819fZM3xricPwe4xN0=";
   };
 
   nativeBuildInputs = [ cmake pkg-config ];
@@ -26,10 +26,8 @@ stdenv.mkDerivation rec {
 
   cmakeFlags = [
     "-DSKIP_UNIT_TESTS=1"
-
     "-DIGC_DIR=${intel-graphics-compiler}"
     "-DOCL_ICD_VENDORDIR=${placeholder "out"}/etc/OpenCL/vendors"
-
     # The install script assumes this path is relative to CMAKE_INSTALL_PREFIX
     "-DCMAKE_INSTALL_LIBDIR=lib"
   ];
@@ -45,10 +43,10 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with lib; {
-    homepage    = "https://github.com/intel/compute-runtime";
+    homepage = "https://github.com/intel/compute-runtime";
     description = "Intel Graphics Compute Runtime for OpenCL. Replaces Beignet for Gen8 (Broadwell) and beyond";
-    license     = licenses.mit;
-    platforms   = platforms.linux;
-    maintainers = with maintainers; [ gloaming ];
+    license = licenses.mit;
+    platforms = [ "x86_64-linux" "aarch64-linux" ];
+    maintainers = with maintainers; [ SuperSandro2000 ];
   };
 }