about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2020-12-30 17:51:42 +0000
committerGitHub <noreply@github.com>2020-12-30 17:51:42 +0000
commit7699bf12fdb160b50bfce74be49c5b28ca9f899c (patch)
tree9cd22c6d6d8bb32d73fbb3deb6a8dd3648958cbe /pkgs/misc
parentbea44d5ebe332260aa34a1bd48250b6364527356 (diff)
parent1fb875c036c4420deeb5f83678de249068a7804f (diff)
downloadnixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar.gz
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar.bz2
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar.lz
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar.xz
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.tar.zst
nixlib-7699bf12fdb160b50bfce74be49c5b28ca9f899c.zip
Merge pull request #107916 from MetaDark/wineStaging
wineStaging: fix mingwSupport
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/base.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/pkgs/misc/emulators/wine/base.nix b/pkgs/misc/emulators/wine/base.nix
index 0be36daac9f9..d8655e558bd6 100644
--- a/pkgs/misc/emulators/wine/base.nix
+++ b/pkgs/misc/emulators/wine/base.nix
@@ -1,6 +1,7 @@
 { stdenv, lib, pkgArches, callPackage,
   name, version, src, mingwGccs, monos, geckos, platforms,
-  pkgconfig, fontforge, makeWrapper, flex, bison,
+  bison, flex, fontforge, makeWrapper, pkg-config,
+  autoconf, hexdump, perl,
   supportFlags,
   patches,
   buildScript ? null, configureFlags ? []
@@ -18,16 +19,24 @@ stdenv.mkDerivation ((lib.optionalAttrs (buildScript != null) {
   inherit name src configureFlags;
 
   # Fixes "Compiler cannot create executables" building wineWow with mingwSupport
-  # FIXME Breaks wineStaging builds
-  strictDeps = supportFlags.mingwSupport;
+  strictDeps = true;
 
   nativeBuildInputs = [
-    pkgconfig fontforge makeWrapper flex bison
+    bison
+    flex
+    fontforge
+    makeWrapper
+    pkg-config
+
+    # Required by staging
+    autoconf
+    hexdump
+    perl
   ]
   ++ lib.optionals supportFlags.mingwSupport mingwGccs;
 
   buildInputs = toBuildInputs pkgArches (with supportFlags; (pkgs:
-  [ pkgs.freetype ]
+  [ pkgs.freetype pkgs.perl pkgs.xorg.libX11 ]
   ++ lib.optional stdenv.isLinux         pkgs.libcap
   ++ lib.optional pngSupport             pkgs.libpng
   ++ lib.optional jpegSupport            pkgs.libjpeg
@@ -72,8 +81,7 @@ stdenv.mkDerivation ((lib.optionalAttrs (buildScript != null) {
   ])
   ++ lib.optionals stdenv.isLinux  (with pkgs.xorg; [
      libXi libXcursor libXrandr libXrender libXxf86vm libXcomposite libXext
-  ])
-  ++ [ pkgs.xorg.libX11 pkgs.perl ]));
+  ])));
 
   patches = [ ] ++ patches';