about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorKira Bruneau <kira.bruneau@gmail.com>2020-12-29 11:51:55 -0500
committerKira Bruneau <kira.bruneau@gmail.com>2020-12-29 21:29:54 -0500
commit1fb875c036c4420deeb5f83678de249068a7804f (patch)
tree0c42ebf3990c7cd9ccf4db3a4e79dc01f7ae7534 /pkgs/misc
parentba4b4aea566ee8783f9196a6b6cefe64cb9ec491 (diff)
downloadnixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar.gz
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar.bz2
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar.lz
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar.xz
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.tar.zst
nixlib-1fb875c036c4420deeb5f83678de249068a7804f.zip
wineStaging: fix mingwSupport
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/base.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/pkgs/misc/emulators/wine/base.nix b/pkgs/misc/emulators/wine/base.nix
index 0be36daac9f9..d8655e558bd6 100644
--- a/pkgs/misc/emulators/wine/base.nix
+++ b/pkgs/misc/emulators/wine/base.nix
@@ -1,6 +1,7 @@
 { stdenv, lib, pkgArches, callPackage,
   name, version, src, mingwGccs, monos, geckos, platforms,
-  pkgconfig, fontforge, makeWrapper, flex, bison,
+  bison, flex, fontforge, makeWrapper, pkg-config,
+  autoconf, hexdump, perl,
   supportFlags,
   patches,
   buildScript ? null, configureFlags ? []
@@ -18,16 +19,24 @@ stdenv.mkDerivation ((lib.optionalAttrs (buildScript != null) {
   inherit name src configureFlags;
 
   # Fixes "Compiler cannot create executables" building wineWow with mingwSupport
-  # FIXME Breaks wineStaging builds
-  strictDeps = supportFlags.mingwSupport;
+  strictDeps = true;
 
   nativeBuildInputs = [
-    pkgconfig fontforge makeWrapper flex bison
+    bison
+    flex
+    fontforge
+    makeWrapper
+    pkg-config
+
+    # Required by staging
+    autoconf
+    hexdump
+    perl
   ]
   ++ lib.optionals supportFlags.mingwSupport mingwGccs;
 
   buildInputs = toBuildInputs pkgArches (with supportFlags; (pkgs:
-  [ pkgs.freetype ]
+  [ pkgs.freetype pkgs.perl pkgs.xorg.libX11 ]
   ++ lib.optional stdenv.isLinux         pkgs.libcap
   ++ lib.optional pngSupport             pkgs.libpng
   ++ lib.optional jpegSupport            pkgs.libjpeg
@@ -72,8 +81,7 @@ stdenv.mkDerivation ((lib.optionalAttrs (buildScript != null) {
   ])
   ++ lib.optionals stdenv.isLinux  (with pkgs.xorg; [
      libXi libXcursor libXrandr libXrender libXxf86vm libXcomposite libXext
-  ])
-  ++ [ pkgs.xorg.libX11 pkgs.perl ]));
+  ])));
 
   patches = [ ] ++ patches';