about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authora-n-n-a-l-e-e <150648636+a-n-n-a-l-e-e@users.noreply.github.com>2024-02-08 16:37:04 -0800
committerGitHub <noreply@github.com>2024-02-08 16:37:04 -0800
commitf1f689a8e8cec16394a26b1f4dda0e6bc3859bbe (patch)
tree7076c0e29d9b9675e7fd72258054b37d904d9439 /pkgs/games
parent75fb7bbc294a633638b17d89657def14951a63e6 (diff)
parentb3d48a4f32ac55594f7da60514e13aa417dafe26 (diff)
downloadnixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar.gz
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar.bz2
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar.lz
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar.xz
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.tar.zst
nixlib-f1f689a8e8cec16394a26b1f4dda0e6bc3859bbe.zip
Merge pull request #284134 from mfrischknecht/fix-crossfire-server-build
crossfire-server: fix build due to missing `cstdint` include
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch13
-rw-r--r--pkgs/games/crossfire/crossfire-server.nix4
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch b/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch
new file mode 100644
index 000000000000..73c69f533613
--- /dev/null
+++ b/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch
@@ -0,0 +1,13 @@
+diff --git a/include/Treasures.h b/include/Treasures.h
+index 614078f..a00b4f6 100644
+--- a/include/Treasures.h
++++ b/include/Treasures.h
+@@ -13,6 +13,8 @@
+ #ifndef TREASURES_H
+ #define TREASURES_H
+ 
++#include <cstdint>
++
+ #include "AssetsCollection.h"
+ 
+ extern "C" {
diff --git a/pkgs/games/crossfire/crossfire-server.nix b/pkgs/games/crossfire/crossfire-server.nix
index 9827aa76c526..214fdf65451b 100644
--- a/pkgs/games/crossfire/crossfire-server.nix
+++ b/pkgs/games/crossfire/crossfire-server.nix
@@ -27,6 +27,10 @@ stdenv.mkDerivation rec {
     rev = "r${rev}";
   };
 
+  patches = [
+    ./add-cstdint-include-to-crossfire-server.patch
+  ];
+
   nativeBuildInputs = [ autoconf automake libtool flex perl check pkg-config python39 ];
   hardeningDisable = [ "format" ];