about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorManuel Frischknecht <manuel.frischknecht@gmail.com>2024-01-26 22:57:20 +0000
committerManuel Frischknecht <manuel.frischknecht@gmail.com>2024-01-26 23:20:49 +0000
commitb3d48a4f32ac55594f7da60514e13aa417dafe26 (patch)
tree2ff2ee6a3a0963b69b4922b97ee52179fb15c19e /pkgs/games
parent3eaa8c80920840cdde783c6f871ca82654e81e78 (diff)
downloadnixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar.gz
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar.bz2
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar.lz
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar.xz
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.tar.zst
nixlib-b3d48a4f32ac55594f7da60514e13aa417dafe26.zip
crossfire-server: fix build due to missing `cstdint` include
GCC 13 stopped including `cstdint` (and other headers) transitively
in most scenarios, causing build failures in programs that relied
on that behavior.

This change adds a missing `cstdint` include via patch to the
`crossfire-server` source, fixing such a build failure.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch13
-rw-r--r--pkgs/games/crossfire/crossfire-server.nix4
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch b/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch
new file mode 100644
index 000000000000..73c69f533613
--- /dev/null
+++ b/pkgs/games/crossfire/add-cstdint-include-to-crossfire-server.patch
@@ -0,0 +1,13 @@
+diff --git a/include/Treasures.h b/include/Treasures.h
+index 614078f..a00b4f6 100644
+--- a/include/Treasures.h
++++ b/include/Treasures.h
+@@ -13,6 +13,8 @@
+ #ifndef TREASURES_H
+ #define TREASURES_H
+ 
++#include <cstdint>
++
+ #include "AssetsCollection.h"
+ 
+ extern "C" {
diff --git a/pkgs/games/crossfire/crossfire-server.nix b/pkgs/games/crossfire/crossfire-server.nix
index 9827aa76c526..214fdf65451b 100644
--- a/pkgs/games/crossfire/crossfire-server.nix
+++ b/pkgs/games/crossfire/crossfire-server.nix
@@ -27,6 +27,10 @@ stdenv.mkDerivation rec {
     rev = "r${rev}";
   };
 
+  patches = [
+    ./add-cstdint-include-to-crossfire-server.patch
+  ];
+
   nativeBuildInputs = [ autoconf automake libtool flex perl check pkg-config python39 ];
   hardeningDisable = [ "format" ];