about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-07-13 15:11:31 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-07-13 15:11:31 -0700
commit333f145d7604f07e3b2164b459b46e075fea81f4 (patch)
treecb9bb91bafeafe64c97fa1054223c0d69cf18848 /pkgs/games
parentd253b3d875d2bae84afbc141754b286e18e2fb7d (diff)
parent7e3c95a0b813394b1a41b73e078d3ffd9e951979 (diff)
downloadnixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar.gz
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar.bz2
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar.lz
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar.xz
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.tar.zst
nixlib-333f145d7604f07e3b2164b459b46e075fea81f4.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/banner/default.nix50
-rw-r--r--pkgs/games/snake4/default.nix27
2 files changed, 39 insertions, 38 deletions
diff --git a/pkgs/games/banner/default.nix b/pkgs/games/banner/default.nix
index e0dac80a8fef..329a23ae81f4 100644
--- a/pkgs/games/banner/default.nix
+++ b/pkgs/games/banner/default.nix
@@ -1,50 +1,24 @@
-{ stdenv, fetchurl, flex, bison, ncurses, buddy, tecla, libsigsegv, gmpxx, makeWrapper }:
+{ stdenv, fetchurl }:
 
-let
-  # Banner depends on two separate libraries. Adding those libraries to
-  # the top-level seems like overkill, though, because no other tools
-  # seems to use them. So we'll build them within this expression.
-  mkDerivation = name: hash: deriv: stdenv.mkDerivation (deriv // {
-    inherit name;
+stdenv.mkDerivation rec {
+  name = "banner-1.3.3";
 
-    src = fetchurl {
-      url = "http://shh.thathost.com/pub-unix/files/${name}.tar.gz";
-      sha256 = hash;
-    };
-
-    configurePhase = "make dep CC=$CC";
-
-    buildPhase = "make OPTIM='-DNDEBUG -O3' CC=$CC";
-
-    installPhase = ''
-      make INSTBASEDIR=$out install
-      if [ -d $out/man ]; then
-        mkdir -p $out/share
-	mv -v $out/man $out/share/
-      fi
-    '';
-  });
-
-  shhopt = mkDerivation "shhopt-1.1.7" "bae94335124efa6fcc2f0a55cabd68c9c90be935bcdb8054d7e5188e0d5da679" {};
-
-  shhmsg = mkDerivation "shhmsg-1.4.1" "f65d45d3a5e415b541a1975e13fe7c5b58e21df6e9306cc3f7901279a9f6d461" {};
-
-in
-
-mkDerivation "banner-1.3.2" "0dc0ac0667b2e884a7f5ad3e467af68cd0fd5917f8c9aa19188e6452aa1fc6d5" {
-  buildInputs = [shhopt shhmsg];
+  src = fetchurl {
+    url = "http://software.cedar-solutions.com/ftp/software/${name}.tar.gz";
+    sha256 = "1njbgba0gzvrmdkvfjgrnvj0i80yi8k7mpkgyxaj07bmv9kc3h5v";
+  };
 
-  meta = {
-    homepage = "http://shh.thathost.com/pub-unix/";
+  meta = with stdenv.lib; {
+    homepage = http://software.cedar-solutions.com/utilities.html;
     description = "Print large banners to ASCII terminals";
-    license = stdenv.lib.licenses.gpl2;
+    license = licenses.gpl2;
 
     longDescription = ''
       An implementation of the traditional Unix-program used to display
       large characters.
     '';
 
-    platforms = stdenv.lib.platforms.all;
-    maintainers = [ stdenv.lib.maintainers.simons ];
+    platforms = platforms.all;
+    maintainers = with maintainers; [ simons pSub ];
   };
 }
diff --git a/pkgs/games/snake4/default.nix b/pkgs/games/snake4/default.nix
new file mode 100644
index 000000000000..081604d2ce8e
--- /dev/null
+++ b/pkgs/games/snake4/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl, shhmsg, shhopt, xlibs }:
+
+stdenv.mkDerivation rec {
+  name = "snake4-1.0.14";
+
+  src = fetchurl {
+    url = "http://shh.thathost.com/pub-unix/files/${name}.tar.gz";
+    sha256 = "14cng9l857np42zixp440mbc8y5675frb6lhsds53j1cws9cncw9";
+  };
+
+  buildInputs = with xlibs; [ shhmsg shhopt libX11 libXt libXpm libXaw libXext];
+
+  preInstall = ''
+    substituteInPlace Makefile --replace "-o \$(OWNER) -g \$(GROUP)" ""
+  '';
+  
+  installFlags = [ "INSTLIBDIR=$(out)/lib"
+                   "INSTBINDIR=$(out)/bin"
+                   "INSTMANDIR=$(out)/man" ];
+
+  meta = with stdenv.lib; {
+    description = "A game starring a fruit-eating snake";
+    homepage = http://shh.thathost.com/pub-unix/html/snake4.html;
+    license = licenses.artistic1;
+    platforms = platforms.linux;
+  };
+}