about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-04-20 18:07:05 -0500
committerGitHub <noreply@github.com>2018-04-20 18:07:05 -0500
commit0fe77f449a68c7735dc5ce274682953e5bb5d6b7 (patch)
treed6084f90be934a3893ef8264e16b306dfc8a1aeb /pkgs/games
parent6b11a5ff138ff695a93b2367bc19f0315ee88ba6 (diff)
parent302c3a7a168c41555dd35576a0ab5c872ba226b3 (diff)
downloadnixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar.gz
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar.bz2
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar.lz
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar.xz
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.tar.zst
nixlib-0fe77f449a68c7735dc5ce274682953e5bb5d6b7.zip
Merge pull request #38950 from tadfisher/quakespasm-userdirs
quakespasm, vkquake: enable userdirs support
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/quakespasm/default.nix14
-rw-r--r--pkgs/games/quakespasm/vulkan.nix8
2 files changed, 13 insertions, 9 deletions
diff --git a/pkgs/games/quakespasm/default.nix b/pkgs/games/quakespasm/default.nix
index be480009b8a6..45c3deef172f 100644
--- a/pkgs/games/quakespasm/default.nix
+++ b/pkgs/games/quakespasm/default.nix
@@ -10,30 +10,32 @@ stdenv.mkDerivation rec {
   };
 
   sourceRoot = "${name}/Quake";
-  
+
   buildInputs = [
     gzip SDL libvorbis libmad
   ];
 
+  buildFlags = [ "DO_USERDIRS=1" ];
+
   preInstall = ''
     mkdir -p "$out/bin"
     substituteInPlace Makefile --replace "/usr/local/games" "$out/bin"
   '';
 
   enableParallelBuilding = true;
-  
+
   meta = {
     description = "An engine for iD software's Quake";
     homepage = http://quakespasm.sourceforge.net/;
     longDescription = ''
       QuakeSpasm is a modern, cross-platform Quake 1 engine based on FitzQuake.
-      It includes support for 64 bit CPUs and custom music playback, a new sound driver, 
+      It includes support for 64 bit CPUs and custom music playback, a new sound driver,
       some graphical niceities, and numerous bug-fixes and other improvements.
-      Quakespasm utilizes either the SDL or SDL2 frameworks, so choose which one 
-      works best for you. SDL is probably less buggy, but SDL2 has nicer features 
+      Quakespasm utilizes either the SDL or SDL2 frameworks, so choose which one
+      works best for you. SDL is probably less buggy, but SDL2 has nicer features
       and smoother mouse input - though no CD support.
     '';
-  
+
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.m3tti ];
   };
diff --git a/pkgs/games/quakespasm/vulkan.nix b/pkgs/games/quakespasm/vulkan.nix
index 675c2ab4b4d8..d53977448f63 100644
--- a/pkgs/games/quakespasm/vulkan.nix
+++ b/pkgs/games/quakespasm/vulkan.nix
@@ -12,11 +12,13 @@ stdenv.mkDerivation rec {
   };
 
   sourceRoot = "source/Quake";
-  
+
   buildInputs = [
     makeWrapper gzip SDL2 libvorbis libmad vulkan-loader.dev
   ];
 
+  buildFlags = [ "DO_USERDIRS=1" ];
+
   preInstall = ''
     mkdir -p "$out/bin"
   '';
@@ -28,7 +30,7 @@ stdenv.mkDerivation rec {
   '';
 
   enableParallelBuilding = true;
-  
+
   meta = {
     description = "Vulkan Quake port based on QuakeSpasm";
     homepage = src.meta.homepage;
@@ -40,7 +42,7 @@ stdenv.mkDerivation rec {
       passes & sub passes, pipeline barriers & synchronization, compute shaders, push &
       specialization constants, CPU/GPU parallelism and memory pooling.
     '';
-  
+
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.gnidorah ];
   };