about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTad Fisher <tadfisher@gmail.com>2018-04-14 13:51:41 -0700
committerTad Fisher <tadfisher@gmail.com>2018-04-14 13:51:41 -0700
commit302c3a7a168c41555dd35576a0ab5c872ba226b3 (patch)
treeb16ebfd788128c49aa2e0fdfa205fa12e6a52d06 /pkgs/games
parenta2cd43efe865b8f3114796f1d6d8dd088b215f76 (diff)
downloadnixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar.gz
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar.bz2
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar.lz
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar.xz
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.tar.zst
nixlib-302c3a7a168c41555dd35576a0ab5c872ba226b3.zip
quakespasm, vkquake: enable userdirs support
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/quakespasm/default.nix14
-rw-r--r--pkgs/games/quakespasm/vulkan.nix8
2 files changed, 13 insertions, 9 deletions
diff --git a/pkgs/games/quakespasm/default.nix b/pkgs/games/quakespasm/default.nix
index be480009b8a6..45c3deef172f 100644
--- a/pkgs/games/quakespasm/default.nix
+++ b/pkgs/games/quakespasm/default.nix
@@ -10,30 +10,32 @@ stdenv.mkDerivation rec {
   };
 
   sourceRoot = "${name}/Quake";
-  
+
   buildInputs = [
     gzip SDL libvorbis libmad
   ];
 
+  buildFlags = [ "DO_USERDIRS=1" ];
+
   preInstall = ''
     mkdir -p "$out/bin"
     substituteInPlace Makefile --replace "/usr/local/games" "$out/bin"
   '';
 
   enableParallelBuilding = true;
-  
+
   meta = {
     description = "An engine for iD software's Quake";
     homepage = http://quakespasm.sourceforge.net/;
     longDescription = ''
       QuakeSpasm is a modern, cross-platform Quake 1 engine based on FitzQuake.
-      It includes support for 64 bit CPUs and custom music playback, a new sound driver, 
+      It includes support for 64 bit CPUs and custom music playback, a new sound driver,
       some graphical niceities, and numerous bug-fixes and other improvements.
-      Quakespasm utilizes either the SDL or SDL2 frameworks, so choose which one 
-      works best for you. SDL is probably less buggy, but SDL2 has nicer features 
+      Quakespasm utilizes either the SDL or SDL2 frameworks, so choose which one
+      works best for you. SDL is probably less buggy, but SDL2 has nicer features
       and smoother mouse input - though no CD support.
     '';
-  
+
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.m3tti ];
   };
diff --git a/pkgs/games/quakespasm/vulkan.nix b/pkgs/games/quakespasm/vulkan.nix
index 675c2ab4b4d8..d53977448f63 100644
--- a/pkgs/games/quakespasm/vulkan.nix
+++ b/pkgs/games/quakespasm/vulkan.nix
@@ -12,11 +12,13 @@ stdenv.mkDerivation rec {
   };
 
   sourceRoot = "source/Quake";
-  
+
   buildInputs = [
     makeWrapper gzip SDL2 libvorbis libmad vulkan-loader.dev
   ];
 
+  buildFlags = [ "DO_USERDIRS=1" ];
+
   preInstall = ''
     mkdir -p "$out/bin"
   '';
@@ -28,7 +30,7 @@ stdenv.mkDerivation rec {
   '';
 
   enableParallelBuilding = true;
-  
+
   meta = {
     description = "Vulkan Quake port based on QuakeSpasm";
     homepage = src.meta.homepage;
@@ -40,7 +42,7 @@ stdenv.mkDerivation rec {
       passes & sub passes, pipeline barriers & synchronization, compute shaders, push &
       specialization constants, CPU/GPU parallelism and memory pooling.
     '';
-  
+
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.gnidorah ];
   };