about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2016-06-16 10:49:00 +0200
committerGitHub <noreply@github.com>2016-06-16 10:49:00 +0200
commitfde378480c4c9304b7b1ad73bb6ba20c63faffcb (patch)
tree6fe5f5a9420c4f8f776a3f0ad33c74ad4349b7cd /pkgs/development
parent2f019896d29cb83a6f82454b0855ea816ef4cba1 (diff)
parent26ef210da2fcf39388fbc34e00c217d506159a88 (diff)
downloadnixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar.gz
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar.bz2
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar.lz
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar.xz
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.tar.zst
nixlib-fde378480c4c9304b7b1ad73bb6ba20c63faffcb.zip
Merge pull request #16252 from luispedro/shiboken_on_py35
shiboken: add support for Python 3.5
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pyside/shiboken.nix3
-rw-r--r--pkgs/development/python-modules/pyside/shiboken_py35.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/pyside/shiboken.nix b/pkgs/development/python-modules/pyside/shiboken.nix
index 549b6275a8ce..80b2325cbf43 100644
--- a/pkgs/development/python-modules/pyside/shiboken.nix
+++ b/pkgs/development/python-modules/pyside/shiboken.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl, cmake, libxml2, libxslt, pysideApiextractor, pysideGeneratorrunner, python, sphinx, qt4, isPy3k, isPy35 }:
 
 # Python 3.5 is not supported: https://github.com/PySide/Shiboken/issues/77
-if isPy35 then throw "shiboken not supported for interpreter ${python.executable}" else stdenv.mkDerivation rec {
+stdenv.mkDerivation rec {
   name = "${python.libPrefix}-pyside-shiboken-${version}";
   version = "1.2.4";
 
@@ -19,6 +19,7 @@ if isPy35 then throw "shiboken not supported for interpreter ${python.executable
     substituteInPlace generator/CMakeLists.txt --replace \
       \"$\{GENERATORRUNNER_PLUGIN_DIR}\" lib/generatorrunner/
   '';
+  patches = if isPy35 then [ ./shiboken_py35.patch ] else null;
 
   cmakeFlags = if isPy3k then "-DUSE_PYTHON3=TRUE" else null;
 
diff --git a/pkgs/development/python-modules/pyside/shiboken_py35.patch b/pkgs/development/python-modules/pyside/shiboken_py35.patch
new file mode 100644
index 000000000000..5642ddc594d1
--- /dev/null
+++ b/pkgs/development/python-modules/pyside/shiboken_py35.patch
@@ -0,0 +1,12 @@
+diff --git a/cmake/Modules/FindPython3Libs.cmake b/cmake/Modules/FindPython3Libs.cmake
+--- a/cmake/Modules/FindPython3Libs.cmake
++++ b/cmake/Modules/FindPython3Libs.cmake
+@@ -27,7 +27,7 @@ INCLUDE(CMakeFindFrameworks)
+ # Search for the python framework on Apple.
+ # CMAKE_FIND_FRAMEWORKS(Python)
+ 
+-FOREACH(_CURRENT_VERSION 3.4 3.3 3.2 3.1 3.0)
++FOREACH(_CURRENT_VERSION 3.5 3.4 3.3 3.2 3.1 3.0)
+   IF(_CURRENT_VERSION GREATER 3.1)
+       SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
+   ELSE()