about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLuis Pedro Coelho <luis@luispedro.org>2016-06-15 19:30:12 +0200
committerLuis Pedro Coelho <luis@luispedro.org>2016-06-15 23:18:34 +0200
commit26ef210da2fcf39388fbc34e00c217d506159a88 (patch)
treea4bd51a9c833be259eb4a420ccbc74f8b0eb8711 /pkgs/development
parent9ff91371d040941c347b95dc7ea081a9c6aa4d0e (diff)
downloadnixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar.gz
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar.bz2
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar.lz
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar.xz
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.tar.zst
nixlib-26ef210da2fcf39388fbc34e00c217d506159a88.zip
shiboken: add support for Python 3.5
Development upstream is stalled, but this is a trivial patch.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/pyside/shiboken.nix3
-rw-r--r--pkgs/development/python-modules/pyside/shiboken_py35.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/pyside/shiboken.nix b/pkgs/development/python-modules/pyside/shiboken.nix
index 549b6275a8ce..80b2325cbf43 100644
--- a/pkgs/development/python-modules/pyside/shiboken.nix
+++ b/pkgs/development/python-modules/pyside/shiboken.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl, cmake, libxml2, libxslt, pysideApiextractor, pysideGeneratorrunner, python, sphinx, qt4, isPy3k, isPy35 }:
 
 # Python 3.5 is not supported: https://github.com/PySide/Shiboken/issues/77
-if isPy35 then throw "shiboken not supported for interpreter ${python.executable}" else stdenv.mkDerivation rec {
+stdenv.mkDerivation rec {
   name = "${python.libPrefix}-pyside-shiboken-${version}";
   version = "1.2.4";
 
@@ -19,6 +19,7 @@ if isPy35 then throw "shiboken not supported for interpreter ${python.executable
     substituteInPlace generator/CMakeLists.txt --replace \
       \"$\{GENERATORRUNNER_PLUGIN_DIR}\" lib/generatorrunner/
   '';
+  patches = if isPy35 then [ ./shiboken_py35.patch ] else null;
 
   cmakeFlags = if isPy3k then "-DUSE_PYTHON3=TRUE" else null;
 
diff --git a/pkgs/development/python-modules/pyside/shiboken_py35.patch b/pkgs/development/python-modules/pyside/shiboken_py35.patch
new file mode 100644
index 000000000000..5642ddc594d1
--- /dev/null
+++ b/pkgs/development/python-modules/pyside/shiboken_py35.patch
@@ -0,0 +1,12 @@
+diff --git a/cmake/Modules/FindPython3Libs.cmake b/cmake/Modules/FindPython3Libs.cmake
+--- a/cmake/Modules/FindPython3Libs.cmake
++++ b/cmake/Modules/FindPython3Libs.cmake
+@@ -27,7 +27,7 @@ INCLUDE(CMakeFindFrameworks)
+ # Search for the python framework on Apple.
+ # CMAKE_FIND_FRAMEWORKS(Python)
+ 
+-FOREACH(_CURRENT_VERSION 3.4 3.3 3.2 3.1 3.0)
++FOREACH(_CURRENT_VERSION 3.5 3.4 3.3 3.2 3.1 3.0)
+   IF(_CURRENT_VERSION GREATER 3.1)
+       SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
+   ELSE()