about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-27 09:49:37 -0400
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-30 00:50:46 -0400
commitf0be1e20bc7bc0ca9234eaf95724a23028f8841d (patch)
treeafd35fe42c591eac51370f413556bc7eddd75cdd /pkgs/development
parent27648d41f0df77a2d4b2e97e62b9c907380ebe52 (diff)
downloadnixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar.gz
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar.bz2
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar.lz
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar.xz
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.tar.zst
nixlib-f0be1e20bc7bc0ca9234eaf95724a23028f8841d.zip
pythonPackages.nose_progressive: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/nose_progressive/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/nose_progressive/default.nix b/pkgs/development/python-modules/nose_progressive/default.nix
new file mode 100644
index 000000000000..98e34212cb8e
--- /dev/null
+++ b/pkgs/development/python-modules/nose_progressive/default.nix
@@ -0,0 +1,32 @@
+{ stdenv
+, buildPythonPackage
+, fetchPypi
+, nose
+, pillow
+, blessings
+, isPy3k
+}:
+
+buildPythonPackage rec {
+  pname = "nose-progressive";
+  version = "1.5.1";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0mfbjv3dcg23q0a130670g7xpfyvgza4wxkj991xxh8w9hs43ga4";
+  };
+
+  buildInputs = [ nose ];
+  propagatedBuildInputs = [ pillow blessings ];
+
+  # fails with obscure error
+  doCheck = !isPy3k;
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/erikrose/nose-progressive;
+    description = "A testrunner with a progress bar and smarter tracebacks";
+    license = licenses.mit;
+    maintainers = with maintainers; [ domenkozar ];
+  };
+
+}