about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-27 09:47:07 -0400
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-30 00:50:45 -0400
commit27648d41f0df77a2d4b2e97e62b9c907380ebe52 (patch)
tree306f863c69f7563a24ab36a8776f14a4fcc52dba /pkgs/development
parent28d2a28d954c5811ba5ce023c91bb2b4dd856730 (diff)
downloadnixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar.gz
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar.bz2
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar.lz
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar.xz
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.tar.zst
nixlib-27648d41f0df77a2d4b2e97e62b9c907380ebe52.zip
pythonPackages.argh: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/argh/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/argh/default.nix b/pkgs/development/python-modules/argh/default.nix
new file mode 100644
index 000000000000..04508b3cc1e8
--- /dev/null
+++ b/pkgs/development/python-modules/argh/default.nix
@@ -0,0 +1,33 @@
+{ stdenv
+, buildPythonPackage
+, fetchPypi
+, pytest
+, py
+, mock
+, pkgs
+}:
+
+buildPythonPackage rec {
+  pname = "argh";
+  version = "0.26.1";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1nqham81ihffc9xmw85dz3rg3v90rw7h0dp3dy0bh3qkp4n499q6";
+  };
+
+  buildInputs = [ pytest py mock pkgs.glibcLocales ];
+
+  checkPhase = ''
+    export LANG="en_US.UTF-8"
+    py.test
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://github.com/neithere/argh/;
+    description = "An unobtrusive argparse wrapper with natural syntax";
+    license = licenses.lgpl2;
+    maintainers = with maintainers; [ domenkozar ];
+  };
+
+}