about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2019-12-17 00:10:04 +0100
committerGitHub <noreply@github.com>2019-12-17 00:10:04 +0100
commitdb59e94059480134b99da9815597b7cc2bf53e81 (patch)
tree8fc11ac1b39dec5bc252cc0ec6351db68a9262d7 /pkgs/development
parent21770f817cf3e755ebc8427a70ec9406b83fb801 (diff)
parent00c3761322ec4d2aa85e66f1c55452ded3f9e681 (diff)
downloadnixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar.gz
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar.bz2
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar.lz
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar.xz
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.tar.zst
nixlib-db59e94059480134b99da9815597b7cc2bf53e81.zip
Merge pull request #75801 from timokau/ecl-libffi-abi
ecl: fix build with libffi 3.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ecl/16.1.2.nix1
-rw-r--r--pkgs/development/compilers/ecl/default.nix4
-rw-r--r--pkgs/development/compilers/ecl/ecl-1.16.2-libffi-3.3-abi.patch15
-rw-r--r--pkgs/development/compilers/ecl/libffi-3.3-abi.patch15
4 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/development/compilers/ecl/16.1.2.nix b/pkgs/development/compilers/ecl/16.1.2.nix
index bede9fa4aa68..a7b2aa6be748 100644
--- a/pkgs/development/compilers/ecl/16.1.2.nix
+++ b/pkgs/development/compilers/ecl/16.1.2.nix
@@ -61,6 +61,7 @@ stdenv.mkDerivation {
       url = "https://git.sagemath.org/sage.git/plain/build/pkgs/ecl/patches/16.1.2-getcwd.patch?id=07d6c37d18811e2b377a9689790a7c5e24da16ba";
       sha256 = "1fbi8gn7rv8nqff5mpaijsrch3k3z7qc5cn4h1vl8qrr8xwqlqhb";
     })
+    ./ecl-1.16.2-libffi-3.3-abi.patch
   ];
 
   hardeningDisable = [ "format" ];
diff --git a/pkgs/development/compilers/ecl/default.nix b/pkgs/development/compilers/ecl/default.nix
index 33ed690772ea..375b38f1dc68 100644
--- a/pkgs/development/compilers/ecl/default.nix
+++ b/pkgs/development/compilers/ecl/default.nix
@@ -35,6 +35,10 @@ stdenv.mkDerivation {
     inherit (s) url sha256;
   };
 
+  patches = [
+    ./libffi-3.3-abi.patch
+  ];
+
   configureFlags = [
     (if threadSupport then "--enable-threads" else "--disable-threads")
     "--with-gmp-prefix=${gmp.dev}"
diff --git a/pkgs/development/compilers/ecl/ecl-1.16.2-libffi-3.3-abi.patch b/pkgs/development/compilers/ecl/ecl-1.16.2-libffi-3.3-abi.patch
new file mode 100644
index 000000000000..28dd7d0805b3
--- /dev/null
+++ b/pkgs/development/compilers/ecl/ecl-1.16.2-libffi-3.3-abi.patch
@@ -0,0 +1,15 @@
+diff --git a/src/c/ffi.d b/src/c/ffi.d
+index 8861303e..8a959c23 100644
+--- a/src/c/ffi.d
++++ b/src/c/ffi.d
+@@ -145,8 +145,8 @@ static struct {
+ #elif defined(X86_WIN64)
+         {@':win64', FFI_WIN64},
+ #elif defined(X86_ANY) || defined(X86) || defined(X86_64)
+-        {@':cdecl', FFI_SYSV},
+-        {@':sysv', FFI_SYSV},
++        {@':cdecl', FFI_UNIX64},
++        {@':sysv', FFI_UNIX64},
+         {@':unix64', FFI_UNIX64},
+ #endif
+ };
diff --git a/pkgs/development/compilers/ecl/libffi-3.3-abi.patch b/pkgs/development/compilers/ecl/libffi-3.3-abi.patch
new file mode 100644
index 000000000000..0a2b5f4dd568
--- /dev/null
+++ b/pkgs/development/compilers/ecl/libffi-3.3-abi.patch
@@ -0,0 +1,15 @@
+diff --git a/src/c/ffi.d b/src/c/ffi.d
+index 8174977a..caa69f39 100644
+--- a/src/c/ffi.d
++++ b/src/c/ffi.d
+@@ -133,8 +133,8 @@ static struct {
+ #elif defined(X86_WIN64)
+   {@':win64', FFI_WIN64},
+ #elif defined(X86_ANY) || defined(X86) || defined(X86_64)
+-  {@':cdecl', FFI_SYSV},
+-  {@':sysv', FFI_SYSV},
++  {@':cdecl', FFI_UNIX64},
++  {@':sysv', FFI_UNIX64},
+   {@':unix64', FFI_UNIX64},
+ #endif
+ };