about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2019-12-16 16:25:06 -0500
committerJon <jonringer@users.noreply.github.com>2019-12-16 14:54:50 -0800
commit21770f817cf3e755ebc8427a70ec9406b83fb801 (patch)
treefd6b031605c4c65704f4133c7ad4ddaf08a66586 /pkgs/development
parentb443abf91494fa416ac1af7c8a751a44349d6253 (diff)
downloadnixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar.gz
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar.bz2
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar.lz
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar.xz
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.tar.zst
nixlib-21770f817cf3e755ebc8427a70ec9406b83fb801.zip
python3Packages.aiorun: init at 2019.11.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/aiorun/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/aiorun/default.nix b/pkgs/development/python-modules/aiorun/default.nix
new file mode 100644
index 000000000000..7e38bb76873a
--- /dev/null
+++ b/pkgs/development/python-modules/aiorun/default.nix
@@ -0,0 +1,45 @@
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
+, isPy27
+, pytest
+, pytestcov
+, uvloop
+}:
+
+buildPythonPackage rec {
+  pname = "aiorun";
+  version = "2019.11.1";
+  format = "flit";
+
+  disabled = isPy27;
+
+  src = fetchFromGitHub {
+    owner = "cjrh";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "04p3sci6af6qqfkcqamsqhmqqrigcwvl4bmx8yv5ppvkyq39pxi7";
+  };
+
+  checkInputs = [
+    pytest
+    pytestcov
+    uvloop
+  ];
+
+  # allow for writable directory for darwin
+  preBuild = ''
+    export HOME=$TMPDIR
+  '';
+
+  checkPhase = ''
+     pytest
+  '';
+
+  meta = with lib; {
+    description = "Boilerplate for asyncio applications";
+    homepage = https://github.com/cjrh/aiorun;
+    license = licenses.asl20;
+    maintainers = [ maintainers.costrouc ];
+  };
+}