about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorjoachifm <joachifm@users.noreply.github.com>2016-04-01 14:57:28 +0000
committerjoachifm <joachifm@users.noreply.github.com>2016-04-01 14:57:28 +0000
commitb9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6 (patch)
tree540a732bd61bb137ef8371085ad38eff519a4ece /pkgs/development
parente4874acae6bf35985c82c03f5653f6a5a3f5ece5 (diff)
parent0de2d2fbcdcea47292662d2509f5d06c81288e48 (diff)
downloadnixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar.gz
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar.bz2
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar.lz
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar.xz
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.tar.zst
nixlib-b9ba6e2f6bd0b8ec555cfb4d5019a6fb873f1bb6.zip
Merge pull request #14297 from elitak/mfi
mfi: init at 2.1.11
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/v8/3.14.nix28
-rw-r--r--pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch27
2 files changed, 55 insertions, 0 deletions
diff --git a/pkgs/development/libraries/v8/3.14.nix b/pkgs/development/libraries/v8/3.14.nix
new file mode 100644
index 000000000000..fee0f868ea92
--- /dev/null
+++ b/pkgs/development/libraries/v8/3.14.nix
@@ -0,0 +1,28 @@
+{ stdenv, callPackage, fetchFromGitHub, python, ... } @ args:
+with stdenv.lib;
+let
+  version = "3.14.5.10";
+  sha256 = "08vhl84166x13b3cbx8y0g99yqx772zd33gawsa1nxqkyrykql6k";
+in
+(callPackage ./generic.nix (args // {
+  inherit version sha256;
+})).overrideDerivation (oldAttrs:{
+  patchPhase = [
+    oldAttrs.patchPhase
+    "sed -i 's,#!/usr/bin/python,#!${python}/bin/python,' build/gyp_v8"
+  ];
+
+  # http://code.google.com/p/v8/issues/detail?id=2149
+  NIX_CFLAGS_COMPILE = concatStringsSep " " [
+    oldAttrs.NIX_CFLAGS_COMPILE
+    "-Wno-unused-local-typedefs"
+    "-Wno-aggressive-loop-optimizations"
+  ];
+
+  src = fetchFromGitHub {
+    owner = "v8";
+    repo = "v8";
+    rev = "${version}";
+    inherit sha256;
+  };
+})
diff --git a/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch b/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch
new file mode 100644
index 000000000000..3bc0fff4d509
--- /dev/null
+++ b/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch
@@ -0,0 +1,27 @@
+From dbe142c4eda0f15fad9fa85743dd11b81292fa8f Mon Sep 17 00:00:00 2001
+From: Timothy J Fontaine <tjfontaine@gmail.com>
+Date: Thu, 23 May 2013 13:57:59 -0700
+Subject: [PATCH] v8: fix GetLocalizedMessage usage
+
+As is the backport of the abort on uncaught exception wouldn't compile
+because we it was passing in `this` when it was unnecessary.
+---
+ deps/v8/src/isolate.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/isolate.cc b/src/isolate.cc
+index 04a438b..5a5293e 100644
+--- a/src/isolate.cc
++++ b/src/isolate.cc
+@@ -1161,7 +1161,7 @@ void Isolate::DoThrow(Object* exception, MessageLocation* location) {
+           (report_exception || can_be_caught_externally)) {
+         fatal_exception_depth++;
+         fprintf(stderr, "%s\n\nFROM\n",
+-          *MessageHandler::GetLocalizedMessage(this, message_obj));
++          *MessageHandler::GetLocalizedMessage(message_obj));
+         PrintCurrentStackTrace(stderr);
+         OS::Abort();
+       }
+-- 
+1.8.1.6
+