about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEric Litak <elitak@gmail.com>2016-03-29 05:27:51 -0700
committerEric Litak <elitak@gmail.com>2016-04-01 02:45:11 -0700
commit0de2d2fbcdcea47292662d2509f5d06c81288e48 (patch)
treea5c3854bb3da98c8e590a5f384128a039a217382 /pkgs/development
parentf1beff232dc734e909f089f79b630420b20e795a (diff)
downloadnixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar.gz
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar.bz2
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar.lz
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar.xz
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.tar.zst
nixlib-0de2d2fbcdcea47292662d2509f5d06c81288e48.zip
mfi: init at 2.1.11
This package has some outdated dependencies, so old versions of mongodb
and v8 had to be re-added as well.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/v8/3.14.nix28
-rw-r--r--pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch27
2 files changed, 55 insertions, 0 deletions
diff --git a/pkgs/development/libraries/v8/3.14.nix b/pkgs/development/libraries/v8/3.14.nix
new file mode 100644
index 000000000000..fee0f868ea92
--- /dev/null
+++ b/pkgs/development/libraries/v8/3.14.nix
@@ -0,0 +1,28 @@
+{ stdenv, callPackage, fetchFromGitHub, python, ... } @ args:
+with stdenv.lib;
+let
+  version = "3.14.5.10";
+  sha256 = "08vhl84166x13b3cbx8y0g99yqx772zd33gawsa1nxqkyrykql6k";
+in
+(callPackage ./generic.nix (args // {
+  inherit version sha256;
+})).overrideDerivation (oldAttrs:{
+  patchPhase = [
+    oldAttrs.patchPhase
+    "sed -i 's,#!/usr/bin/python,#!${python}/bin/python,' build/gyp_v8"
+  ];
+
+  # http://code.google.com/p/v8/issues/detail?id=2149
+  NIX_CFLAGS_COMPILE = concatStringsSep " " [
+    oldAttrs.NIX_CFLAGS_COMPILE
+    "-Wno-unused-local-typedefs"
+    "-Wno-aggressive-loop-optimizations"
+  ];
+
+  src = fetchFromGitHub {
+    owner = "v8";
+    repo = "v8";
+    rev = "${version}";
+    inherit sha256;
+  };
+})
diff --git a/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch b/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch
new file mode 100644
index 000000000000..3bc0fff4d509
--- /dev/null
+++ b/pkgs/development/libraries/v8/fix-GetLocalizedMessage-usage.patch
@@ -0,0 +1,27 @@
+From dbe142c4eda0f15fad9fa85743dd11b81292fa8f Mon Sep 17 00:00:00 2001
+From: Timothy J Fontaine <tjfontaine@gmail.com>
+Date: Thu, 23 May 2013 13:57:59 -0700
+Subject: [PATCH] v8: fix GetLocalizedMessage usage
+
+As is the backport of the abort on uncaught exception wouldn't compile
+because we it was passing in `this` when it was unnecessary.
+---
+ deps/v8/src/isolate.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/isolate.cc b/src/isolate.cc
+index 04a438b..5a5293e 100644
+--- a/src/isolate.cc
++++ b/src/isolate.cc
+@@ -1161,7 +1161,7 @@ void Isolate::DoThrow(Object* exception, MessageLocation* location) {
+           (report_exception || can_be_caught_externally)) {
+         fatal_exception_depth++;
+         fprintf(stderr, "%s\n\nFROM\n",
+-          *MessageHandler::GetLocalizedMessage(this, message_obj));
++          *MessageHandler::GetLocalizedMessage(message_obj));
+         PrintCurrentStackTrace(stderr);
+         OS::Abort();
+       }
+-- 
+1.8.1.6
+