about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-09-24 15:58:45 +0100
committerGitHub <noreply@github.com>2017-09-24 15:58:45 +0100
commit83440984e337189081c59849eb334820d85382c7 (patch)
treef8a9335d316c78be15b6f8e8c1c96a4e19692047 /pkgs/development
parent975c7b22044e7d1568efa2b01d46a4fc917420c7 (diff)
parentdd9959295205489016e1877f96a0f0c83eef5743 (diff)
downloadnixlib-83440984e337189081c59849eb334820d85382c7.tar
nixlib-83440984e337189081c59849eb334820d85382c7.tar.gz
nixlib-83440984e337189081c59849eb334820d85382c7.tar.bz2
nixlib-83440984e337189081c59849eb334820d85382c7.tar.lz
nixlib-83440984e337189081c59849eb334820d85382c7.tar.xz
nixlib-83440984e337189081c59849eb334820d85382c7.tar.zst
nixlib-83440984e337189081c59849eb334820d85382c7.zip
Merge pull request #29691 from veprbl/simanneal
pythonPackages.simanneal: init at 0.4.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/simanneal/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/simanneal/default.nix b/pkgs/development/python-modules/simanneal/default.nix
new file mode 100644
index 000000000000..e3f65b6660c2
--- /dev/null
+++ b/pkgs/development/python-modules/simanneal/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchFromGitHub, buildPythonPackage, pytest }:
+
+buildPythonPackage rec {
+  pname = "simanneal";
+  version = "0.4.1";
+  name = "${pname}-${version}";
+
+  src = fetchFromGitHub {
+    owner = "perrygeo";
+    repo = "simanneal";
+    rev = version;
+    sha256 = "12499wvf7ii7cy8z2f1d472p7q9napg1lj0h9xx8l1mbr1hjlp3q";
+  };
+
+  checkInputs = [ pytest ];
+  checkPhase = "pytest tests";
+
+  meta = with stdenv.lib; {
+    description = "A python implementation of the simulated annealing optimization technique";
+    homepage = https://github.com/perrygeo/simanneal;
+    license = licenses.isc;
+    maintainers = with maintainers; [ veprbl ];
+  };
+}