about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJoerg Thalheim <joerg@thalheim.io>2017-09-24 15:57:49 +0100
committerJoerg Thalheim <joerg@thalheim.io>2017-09-24 15:57:49 +0100
commitdd9959295205489016e1877f96a0f0c83eef5743 (patch)
tree9a45ae80e90167d4261d1bff8244a980e833d0ec /pkgs/development
parentde1480e079974b06d41a5a8c2c3de01320833d16 (diff)
downloadnixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar.gz
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar.bz2
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar.lz
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar.xz
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.tar.zst
nixlib-dd9959295205489016e1877f96a0f0c83eef5743.zip
python.pkgs.simanneal: enable tests
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/simanneal/default.nix19
1 files changed, 12 insertions, 7 deletions
diff --git a/pkgs/development/python-modules/simanneal/default.nix b/pkgs/development/python-modules/simanneal/default.nix
index 66a9628673b3..e3f65b6660c2 100644
--- a/pkgs/development/python-modules/simanneal/default.nix
+++ b/pkgs/development/python-modules/simanneal/default.nix
@@ -1,19 +1,24 @@
-{ lib, fetchPypi, buildPythonPackage }:
+{ stdenv, fetchFromGitHub, buildPythonPackage, pytest }:
 
 buildPythonPackage rec {
   pname = "simanneal";
   version = "0.4.1";
   name = "${pname}-${version}";
 
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "1ib1hv2adq6x25z13nb4s1asci6dqarpyhpdq144y2rqqff2m01x";
+  src = fetchFromGitHub {
+    owner = "perrygeo";
+    repo = "simanneal";
+    rev = version;
+    sha256 = "12499wvf7ii7cy8z2f1d472p7q9napg1lj0h9xx8l1mbr1hjlp3q";
   };
 
-  meta = {
+  checkInputs = [ pytest ];
+  checkPhase = "pytest tests";
+
+  meta = with stdenv.lib; {
     description = "A python implementation of the simulated annealing optimization technique";
     homepage = https://github.com/perrygeo/simanneal;
-    license = lib.licenses.isc;
-    maintainers = with lib.maintainers; [ veprbl ];
+    license = licenses.isc;
+    maintainers = with maintainers; [ veprbl ];
   };
 }