about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorwmertens <Wout.Mertens@gmail.com>2014-12-18 17:49:10 +0100
committerwmertens <Wout.Mertens@gmail.com>2014-12-18 17:49:10 +0100
commit6fa7ea053721f2d648353d35741bc1eaa465ee57 (patch)
tree75247b3c7aa3cc303806c75ca1da6e23492ecddd /pkgs/development
parent63c14e259d4c8fc3ff706ccd620d3f794426ff1d (diff)
parent96f4758d098e0bf1cfb3e64111cb5b07fe582da0 (diff)
downloadnixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar.gz
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar.bz2
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar.lz
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar.xz
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.tar.zst
nixlib-6fa7ea053721f2d648353d35741bc1eaa465ee57.zip
Merge pull request #5383 from robberer/tmp1
php: make curl wrappers optional
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/php/5.4.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/development/interpreters/php/5.4.nix b/pkgs/development/interpreters/php/5.4.nix
index 9c4d1563a61d..a5fbac680f90 100644
--- a/pkgs/development/interpreters/php/5.4.nix
+++ b/pkgs/development/interpreters/php/5.4.nix
@@ -41,10 +41,14 @@ composableDerivation.composableDerivation {} ( fixed : let inherit (fixed.fixed)
       };
 
       curl = {
-        configureFlags = ["--with-curl=${curl}" "--with-curlwrappers"];
+        configureFlags = ["--with-curl=${curl}"];
         buildInputs = [curl openssl];
       };
 
+      curlWrappers = {
+        configureFlags = ["--with-curlwrappers"];
+      };
+
       zlib = {
         configureFlags = ["--with-zlib=${zlib}"];
         buildInputs = [zlib];
@@ -199,6 +203,7 @@ composableDerivation.composableDerivation {} ( fixed : let inherit (fixed.fixed)
     bcmathSupport = config.php.bcmath or true;
     socketsSupport = config.php.sockets or true;
     curlSupport = config.php.curl or true;
+    curlWrappersSupport = config.php.curlWrappers or false;
     gettextSupport = config.php.gettext or true;
     pcntlSupport = config.php.pcntl or true;
     postgresqlSupport = config.php.postgresql or true;