about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLongrin Wischnewski <robberer@freakmail.de>2014-12-18 09:04:26 +0100
committerLongrin Wischnewski <robberer@freakmail.de>2014-12-18 09:04:26 +0100
commit96f4758d098e0bf1cfb3e64111cb5b07fe582da0 (patch)
tree65c8b4130f83eddbd15bbcc73dcdbd8c7d501d34 /pkgs/development
parent1a504e3fb72fab10799cf07ba8eaa942bb7e585b (diff)
downloadnixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar.gz
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar.bz2
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar.lz
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar.xz
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.tar.zst
nixlib-96f4758d098e0bf1cfb3e64111cb5b07fe582da0.zip
php: make curl wrappers optional
cURL wrappers are experimental and break any application/library
that rely on $http_response_header
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/php/5.4.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/development/interpreters/php/5.4.nix b/pkgs/development/interpreters/php/5.4.nix
index 9c4d1563a61d..a5fbac680f90 100644
--- a/pkgs/development/interpreters/php/5.4.nix
+++ b/pkgs/development/interpreters/php/5.4.nix
@@ -41,10 +41,14 @@ composableDerivation.composableDerivation {} ( fixed : let inherit (fixed.fixed)
       };
 
       curl = {
-        configureFlags = ["--with-curl=${curl}" "--with-curlwrappers"];
+        configureFlags = ["--with-curl=${curl}"];
         buildInputs = [curl openssl];
       };
 
+      curlWrappers = {
+        configureFlags = ["--with-curlwrappers"];
+      };
+
       zlib = {
         configureFlags = ["--with-zlib=${zlib}"];
         buildInputs = [zlib];
@@ -199,6 +203,7 @@ composableDerivation.composableDerivation {} ( fixed : let inherit (fixed.fixed)
     bcmathSupport = config.php.bcmath or true;
     socketsSupport = config.php.sockets or true;
     curlSupport = config.php.curl or true;
+    curlWrappersSupport = config.php.curlWrappers or false;
     gettextSupport = config.php.gettext or true;
     pcntlSupport = config.php.pcntl or true;
     postgresqlSupport = config.php.postgresql or true;