about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2016-04-02 14:20:19 +0100
committerDomen Kožar <domen@dev.si>2016-04-02 14:20:19 +0100
commit3e23865bbef2bc965ad70d0cc1d06663948ae98c (patch)
treeef12f0b4138bf952c2662de939d603bf7cfefd2a /pkgs/development
parent530f59979abd2271e4b02c404f716c3b2c7b9fa4 (diff)
parent456ce674623e186ca026356635b3711c89e227d6 (diff)
downloadnixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar.gz
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar.bz2
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar.lz
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar.xz
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.tar.zst
nixlib-3e23865bbef2bc965ad70d0cc1d06663948ae98c.zip
Merge pull request #14385 from yurrriq/patch-erlang-R17
erlangR17: fix build on OS X
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/erlang/R17.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/development/interpreters/erlang/R17.nix b/pkgs/development/interpreters/erlang/R17.nix
index e06b2741d35c..8096ca555a44 100644
--- a/pkgs/development/interpreters/erlang/R17.nix
+++ b/pkgs/development/interpreters/erlang/R17.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl, perl, gnum4, ncurses, openssl
 , gnused, gawk, makeWrapper
+, Carbon, Cocoa
 , odbcSupport ? false, unixODBC ? null
 , wxSupport ? true, mesa ? null, wxGTK ? null, xorg ? null, wxmac ? null
 , javacSupport ? false, openjdk ? null
@@ -27,9 +28,10 @@ stdenv.mkDerivation rec {
 
   buildInputs =
     [ perl gnum4 ncurses openssl makeWrapper
-    ] ++ optional wxSupport (if stdenv.isDarwin then [ wxmac ] else [ mesa wxGTK xorg.libX11 ])
-      ++ optional odbcSupport [ unixODBC ]
-      ++ optional javacSupport [ openjdk ];
+    ] ++ optionals wxSupport (if stdenv.isDarwin then [ wxmac ] else [ mesa wxGTK xorg.libX11 ])
+      ++ optional odbcSupport unixODBC
+      ++ optional javacSupport openjdk
+      ++ stdenv.lib.optionals stdenv.isDarwin [ Carbon Cocoa ];
 
   patchPhase = '' sed -i "s@/bin/rm@rm@" lib/odbc/configure erts/configure '';