about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEric Bailey <eric@ericb.me>2016-03-21 19:19:32 -0500
committerEric Bailey <eric@ericb.me>2016-04-01 19:06:20 -0500
commit456ce674623e186ca026356635b3711c89e227d6 (patch)
tree5269e219c7f4853dd33ab82a0f084b631a64c983 /pkgs/development
parent6a4ca7e43a54fccc6ecbb0f195e5123098fc4976 (diff)
downloadnixlib-456ce674623e186ca026356635b3711c89e227d6.tar
nixlib-456ce674623e186ca026356635b3711c89e227d6.tar.gz
nixlib-456ce674623e186ca026356635b3711c89e227d6.tar.bz2
nixlib-456ce674623e186ca026356635b3711c89e227d6.tar.lz
nixlib-456ce674623e186ca026356635b3711c89e227d6.tar.xz
nixlib-456ce674623e186ca026356635b3711c89e227d6.tar.zst
nixlib-456ce674623e186ca026356635b3711c89e227d6.zip
Patch erlang-R17
Fix R17 build on OS X, modeling changes after R18,
i.e. inherit Carbon, Cocoa.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/erlang/R17.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/development/interpreters/erlang/R17.nix b/pkgs/development/interpreters/erlang/R17.nix
index e06b2741d35c..8096ca555a44 100644
--- a/pkgs/development/interpreters/erlang/R17.nix
+++ b/pkgs/development/interpreters/erlang/R17.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl, perl, gnum4, ncurses, openssl
 , gnused, gawk, makeWrapper
+, Carbon, Cocoa
 , odbcSupport ? false, unixODBC ? null
 , wxSupport ? true, mesa ? null, wxGTK ? null, xorg ? null, wxmac ? null
 , javacSupport ? false, openjdk ? null
@@ -27,9 +28,10 @@ stdenv.mkDerivation rec {
 
   buildInputs =
     [ perl gnum4 ncurses openssl makeWrapper
-    ] ++ optional wxSupport (if stdenv.isDarwin then [ wxmac ] else [ mesa wxGTK xorg.libX11 ])
-      ++ optional odbcSupport [ unixODBC ]
-      ++ optional javacSupport [ openjdk ];
+    ] ++ optionals wxSupport (if stdenv.isDarwin then [ wxmac ] else [ mesa wxGTK xorg.libX11 ])
+      ++ optional odbcSupport unixODBC
+      ++ optional javacSupport openjdk
+      ++ stdenv.lib.optionals stdenv.isDarwin [ Carbon Cocoa ];
 
   patchPhase = '' sed -i "s@/bin/rm@rm@" lib/odbc/configure erts/configure '';