about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2018-12-10 20:05:12 +0000
committerRobin Gloster <mail@glob.in>2018-12-11 18:13:21 +0100
commit2ebe19f3302ee21871cfab11cdadd13f38b51261 (patch)
treeb95a0e28956df79a1ac470a415e77069aa2c718e /pkgs/development
parent10ba78757f4f3630eb37ebae83d4b73353f2fbcd (diff)
downloadnixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar.gz
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar.bz2
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar.lz
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar.xz
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.tar.zst
nixlib-2ebe19f3302ee21871cfab11cdadd13f38b51261.zip
openldap: fix cross-build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/openldap/default.nix33
1 files changed, 21 insertions, 12 deletions
diff --git a/pkgs/development/libraries/openldap/default.nix b/pkgs/development/libraries/openldap/default.nix
index 16e00e9f2b95..0a5f83d1c7c6 100644
--- a/pkgs/development/libraries/openldap/default.nix
+++ b/pkgs/development/libraries/openldap/default.nix
@@ -13,18 +13,27 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  buildInputs = [ openssl cyrus_sasl db groff libtool ];
-
-  configureFlags =
-    [ "--enable-overlays"
-      "--disable-dependency-tracking"   # speeds up one-time build
-      "--enable-modules"
-      "--sysconfdir=/etc"
-      "--localstatedir=/var"
-      "--enable-crypt"
-    ] ++ stdenv.lib.optional (openssl == null) "--without-tls"
-      ++ stdenv.lib.optional (cyrus_sasl == null) "--without-cyrus-sasl"
-      ++ stdenv.lib.optional stdenv.isFreeBSD "--with-pic";
+  nativeBuildInputs = [ groff ];
+
+  buildInputs = [ openssl cyrus_sasl db libtool ];
+
+  # Disable install stripping as it breaks cross-compiling.
+  # We strip binaries anyway in fixupPhase.
+  makeFlags= [ "STRIP=" ];
+
+  configureFlags = [
+    "--enable-overlays"
+    "--disable-dependency-tracking"   # speeds up one-time build
+    "--enable-modules"
+    "--sysconfdir=/etc"
+    "--localstatedir=/var"
+    "--enable-crypt"
+  ] ++ stdenv.lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
+    "--with-yielding_select=yes"
+    "ac_cv_func_memcmp_working=yes"
+  ] ++ stdenv.lib.optional (openssl == null) "--without-tls"
+    ++ stdenv.lib.optional (cyrus_sasl == null) "--without-cyrus-sasl"
+    ++ stdenv.lib.optional stdenv.isFreeBSD "--with-pic";
 
   doCheck = false; # needs a running LDAP server