about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-12-11 08:01:58 +0000
committerzimbatm <zimbatm@zimbatm.com>2018-12-11 09:01:58 +0100
commit10ba78757f4f3630eb37ebae83d4b73353f2fbcd (patch)
tree8331f93e2ac256b263657c961c3b09f37bb6cc84 /pkgs/development
parentfee79f543e90f5904a5c8f258dede77e6f1f10e0 (diff)
downloadnixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar.gz
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar.bz2
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar.lz
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar.xz
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.tar.zst
nixlib-10ba78757f4f3630eb37ebae83d4b73353f2fbcd.zip
ruby: fix cross-build (#51842)
Enable autoreconfHook by default: The build tried to execute autoconf, which was
in the wrong build input. Regenerating autotools configure files is always a good
idea since it delivers fixes.
Also move groff to the native since it is only used at build-time
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/ruby/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/pkgs/development/interpreters/ruby/default.nix b/pkgs/development/interpreters/ruby/default.nix
index f1d48578541e..1ee5c0b57ace 100644
--- a/pkgs/development/interpreters/ruby/default.nix
+++ b/pkgs/development/interpreters/ruby/default.nix
@@ -73,20 +73,16 @@ let
         # Have `configure' avoid `/usr/bin/nroff' in non-chroot builds.
         NROFF = if docSupport then "${groff}/bin/nroff" else null;
 
-        nativeBuildInputs =
-             ops useRailsExpress [ autoreconfHook bison ]
-          ++ ops (stdenv.buildPlatform != stdenv.hostPlatform) [
-               buildPackages.ruby
-             ];
+        nativeBuildInputs = [ autoreconfHook bison ]
+          ++ (op docSupport groff)
+          ++ op (stdenv.buildPlatform != stdenv.hostPlatform) buildPackages.ruby;
         buildInputs =
              (op fiddleSupport libffi)
           ++ (ops cursesSupport [ ncurses readline ])
-          ++ (op docSupport groff)
           ++ (op zlibSupport zlib)
           ++ (op opensslSupport openssl)
           ++ (op gdbmSupport gdbm)
           ++ (op yamlSupport libyaml)
-          ++ (op isRuby25 autoconf)
           # Looks like ruby fails to build on darwin without readline even if curses
           # support is not enabled, so add readline to the build inputs if curses
           # support is disabled (if it's enabled, we already have it) and we're
@@ -149,7 +145,7 @@ let
         postInstall = ''
           # Update rubygems
           pushd rubygems
-          ${buildRuby} setup.rb
+          ${buildRuby} setup.rb --destdir $GEM_HOME
           popd
 
           # Remove unnecessary groff reference from runtime closure, since it's big