about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-02-24 10:06:07 +0100
committerPeter Simons <simons@cryp.to>2019-02-24 10:14:29 +0100
commit1f2d0a356948316453a5f83be0fc6e603c311cbf (patch)
treeb2f77f089abd2f024a11cbb99a225565ad379cf0 /pkgs/development
parent10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771 (diff)
downloadnixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar.gz
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar.bz2
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar.lz
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar.xz
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.tar.zst
nixlib-1f2d0a356948316453a5f83be0fc6e603c311cbf.zip
haskell-base-compat-batteries: fix build with ghc 8.2.2 and 8.4.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.2.x.nix3
-rw-r--r--pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix3
2 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.2.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.2.x.nix
index c2fbb4d6126c..58e84b154856 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.2.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.2.x.nix
@@ -92,7 +92,8 @@ self: super: {
   hackage-db_2_0_1 = super.hackage-db_2_0_1.overrideScope (self: super: { Cabal = self.Cabal_2_2_0_1; });
   stack = super.stack.overrideScope (self: super: { Cabal = self.Cabal_2_2_0_1; });
 
-  # GHC 8.2 doesn't have semigroups included by default
+  # Older GHC versions need these additional dependencies.
   ListLike = addBuildDepend super.ListLike self.semigroups;
+  base-compat-batteries = addBuildDepend super.base-compat-batteries self.contravariant;
 
 }
diff --git a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
index 2a72eced2ba9..417bf0effcd9 100644
--- a/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
+++ b/pkgs/development/haskell-modules/configuration-ghc-8.4.x.nix
@@ -71,7 +71,8 @@ self: super: {
     yaml = self.yaml_0_11_0_0;
   };
 
-  # cabal2nix doesn't list this because of a conditional on the GHC version.
+  # Older GHC versions need these additional dependencies.
   aeson = addBuildDepend super.aeson self.contravariant;
+  base-compat-batteries = addBuildDepend super.base-compat-batteries self.contravariant;
 
 }