about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-02-24 10:01:01 +0100
committerPeter Simons <simons@cryp.to>2019-02-24 10:14:29 +0100
commit10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771 (patch)
tree7e021907f02150a767e0baf119cf3e639631dc24 /pkgs/development
parentbbd82be63ed15c73cd9e1fba7269ee794dcd7583 (diff)
downloadnixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar.gz
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar.bz2
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar.lz
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar.xz
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.tar.zst
nixlib-10e7cf92bc9508ac42bb2dcf7ee2a7e261d49771.zip
haskell-ci: enable command-line completion
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 48af76a79a00..e27348b94556 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1223,14 +1223,15 @@ self: super: {
   tasty-hedgehog = dontCheck super.tasty-hedgehog;
 
   # The latest release version is ancient. You really need this tool from git.
-  haskell-ci = addBuildDepend (overrideSrc (dontCheck super.haskell-ci) {
-    version = "2019.02.22-git";
-    src = pkgs.fetchFromGitHub {
-      owner = "haskell-CI";
-      repo = "haskell-ci";
-      rev = "3a861aa7d6099296a9ac1003c7218e3ed831ca8c";
-      sha256 = "0hwfg3ab5mh3xml3nlabbr1x8bhg26gw6sxn8bgb8bh6r0ccq9pi";
-    };
-    }) (with self; [base-compat generic-lens microlens optparse-applicative ShellCheck]);
+  haskell-ci = generateOptparseApplicativeCompletion "haskell-ci"
+    (addBuildDepend (overrideSrc (dontCheck super.haskell-ci) {
+      version = "2019.02.22-git";
+      src = pkgs.fetchFromGitHub {
+        owner = "haskell-CI";
+        repo = "haskell-ci";
+        rev = "3a861aa7d6099296a9ac1003c7218e3ed831ca8c";
+        sha256 = "0hwfg3ab5mh3xml3nlabbr1x8bhg26gw6sxn8bgb8bh6r0ccq9pi";
+      };
+  }) (with self; [base-compat generic-lens microlens optparse-applicative ShellCheck]));
 
 } // import ./configuration-tensorflow.nix {inherit pkgs haskellLib;} self super