about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-02-24 09:56:29 +0100
committerPeter Simons <simons@cryp.to>2019-02-24 10:14:29 +0100
commitbbd82be63ed15c73cd9e1fba7269ee794dcd7583 (patch)
tree3606bd28b4d1c75beec0a5d49376a55b7458bef5 /pkgs/development
parentc3f38ddd8bfee421de8d0706818b0d719b249839 (diff)
downloadnixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar.gz
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar.bz2
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar.lz
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar.xz
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.tar.zst
nixlib-bbd82be63ed15c73cd9e1fba7269ee794dcd7583.zip
haskell-ci: add an override that uses the latest git version
The latest Hackage release is too old to be useful, unfortunately.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 5971ee6f9c84..48af76a79a00 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -1222,4 +1222,15 @@ self: super: {
   # https://github.com/qfpl/tasty-hedgehog/issues/24
   tasty-hedgehog = dontCheck super.tasty-hedgehog;
 
+  # The latest release version is ancient. You really need this tool from git.
+  haskell-ci = addBuildDepend (overrideSrc (dontCheck super.haskell-ci) {
+    version = "2019.02.22-git";
+    src = pkgs.fetchFromGitHub {
+      owner = "haskell-CI";
+      repo = "haskell-ci";
+      rev = "3a861aa7d6099296a9ac1003c7218e3ed831ca8c";
+      sha256 = "0hwfg3ab5mh3xml3nlabbr1x8bhg26gw6sxn8bgb8bh6r0ccq9pi";
+    };
+    }) (with self; [base-compat generic-lens microlens optparse-applicative ShellCheck]);
+
 } // import ./configuration-tensorflow.nix {inherit pkgs haskellLib;} self super