about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorEmily Trau <13267947+emilytrau@users.noreply.github.com>2023-12-02 01:16:38 +1100
committerGitHub <noreply@github.com>2023-12-02 01:16:38 +1100
commiteb7947e3996d45fd8325c3d7c60f8a7c5065665c (patch)
treef28f9cd38edd8b5868855b4384f88557699cb07f /pkgs/data
parenta69680dd474479b1b82e1b607ea0a8ff0856b559 (diff)
parent2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad (diff)
downloadnixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar.gz
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar.bz2
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar.lz
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar.xz
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.tar.zst
nixlib-eb7947e3996d45fd8325c3d7c60f8a7c5065665c.zip
Merge pull request #167228 from nosewings/submit/quivira
quivira: init at 4.1
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/quivira/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/data/fonts/quivira/default.nix b/pkgs/data/fonts/quivira/default.nix
new file mode 100644
index 000000000000..8affc4f6c729
--- /dev/null
+++ b/pkgs/data/fonts/quivira/default.nix
@@ -0,0 +1,29 @@
+{ lib, fetchurl }:
+let
+  pname = "quivira";
+  version = "4.1";
+in fetchurl {
+  name = "${pname}-${version}";
+  url = "http://www.quivira-font.com/files/Quivira.otf";
+
+  # Download the source file to a temporary directory so that $out can be a
+  # directory with the expected structure.
+  downloadToTemp = true;
+  # recursiveHash needs to be true because $out is going to be a directory.
+  recursiveHash = true;
+  postFetch = ''
+    install -D $downloadedFile $out/share/fonts/opentype/Quivira.otf
+  '';
+
+  sha256 = "Hhl+0Oc5DDohOpBbEARMunMYCpr6nn4X6RgpQeEksNo=";
+  meta = {
+    description = "a free Unicode font in the OpenType format which is supported by every usual office program or printer";
+    homepage = "http://www.quivira-font.com/";
+    license = lib.licenses.publicDomain;
+    maintainers = [ lib.maintainers.nosewings ];
+    # From the homepage: "If you try to install Quivira on a Mac,
+    # you will get an error message about the 'post table
+    # usability'."
+    platforms = lib.filter (platform: !lib.hasInfix "darwin" platform) lib.platforms.all;
+  };
+}