about summary refs log tree commit diff
path: root/pkgs/data
diff options
context:
space:
mode:
authorNicholas Coltharp <coltharp@pdx.edu>2023-01-31 16:37:00 -0600
committerEmily Trau <emily@downunderctf.com>2023-12-01 16:01:17 +1100
commit2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad (patch)
treec43420fa07839eacbdb482b4be736cdb42a84c77 /pkgs/data
parentcd5d34fe4e57529bb1046f5b137e153a1c7b7140 (diff)
downloadnixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar.gz
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar.bz2
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar.lz
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar.xz
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.tar.zst
nixlib-2c498bff9c96d8f055f5ecc1a739ba614b2eb6ad.zip
quivira: init at 4.1
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/quivira/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/data/fonts/quivira/default.nix b/pkgs/data/fonts/quivira/default.nix
new file mode 100644
index 000000000000..8affc4f6c729
--- /dev/null
+++ b/pkgs/data/fonts/quivira/default.nix
@@ -0,0 +1,29 @@
+{ lib, fetchurl }:
+let
+  pname = "quivira";
+  version = "4.1";
+in fetchurl {
+  name = "${pname}-${version}";
+  url = "http://www.quivira-font.com/files/Quivira.otf";
+
+  # Download the source file to a temporary directory so that $out can be a
+  # directory with the expected structure.
+  downloadToTemp = true;
+  # recursiveHash needs to be true because $out is going to be a directory.
+  recursiveHash = true;
+  postFetch = ''
+    install -D $downloadedFile $out/share/fonts/opentype/Quivira.otf
+  '';
+
+  sha256 = "Hhl+0Oc5DDohOpBbEARMunMYCpr6nn4X6RgpQeEksNo=";
+  meta = {
+    description = "a free Unicode font in the OpenType format which is supported by every usual office program or printer";
+    homepage = "http://www.quivira-font.com/";
+    license = lib.licenses.publicDomain;
+    maintainers = [ lib.maintainers.nosewings ];
+    # From the homepage: "If you try to install Quivira on a Mac,
+    # you will get an error message about the 'post table
+    # usability'."
+    platforms = lib.filter (platform: !lib.hasInfix "darwin" platform) lib.platforms.all;
+  };
+}