about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorjopejoe1 <johannes@joens.email>2023-12-06 19:51:42 +0100
committerJörg Thalheim <Mic92@users.noreply.github.com>2023-12-13 21:28:44 +0100
commite9b49cdba86d8532856987ec846d16a16ecf44b2 (patch)
treee76d32ca7f5eac21dcbd0e9f38747363a011c409 /pkgs/by-name
parentb81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc (diff)
downloadnixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar.gz
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar.bz2
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar.lz
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar.xz
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.tar.zst
nixlib-e9b49cdba86d8532856987ec846d16a16ecf44b2.zip
noto-fonts-cjk-serif: move out of noto-fonts file
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/no/noto-fonts-cjk-serif/package.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/pkgs/by-name/no/noto-fonts-cjk-serif/package.nix b/pkgs/by-name/no/noto-fonts-cjk-serif/package.nix
new file mode 100644
index 000000000000..d9fddcc684c4
--- /dev/null
+++ b/pkgs/by-name/no/noto-fonts-cjk-serif/package.nix
@@ -0,0 +1,49 @@
+{ lib
+, stdenvNoCC
+, fetchFromGitHub
+, nixosTests
+, gitUpdater
+}:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "noto-fonts-cjk-serif";
+  version = "2.002";
+
+  src = fetchFromGitHub {
+    owner = "notofonts";
+    repo = "noto-cjk";
+    rev = "Serif${version}";
+    hash = "sha256-GLjpTAiHfygj1J4AdUVDJh8kykkFOglq+h4kyat5W9s=";
+    sparseCheckout = [ "Serif/Variable/OTC" ];
+  };
+
+  installPhase = ''
+    install -m444 -Dt $out/share/fonts/opentype/noto-cjk Serif/Variable/OTC/*.otf.ttc
+  '';
+
+  passthru.tests.noto-fonts = nixosTests.noto-fonts;
+
+  passthru.updateScript = gitUpdater {
+    rev-prefix = "Serif";
+  };
+
+  meta = with lib; {
+    description = "Beautiful and free fonts for CJK languages";
+    homepage = "https://www.google.com/get/noto/help/cjk/";
+    longDescription = ''
+      Noto Serif CJK is a serif typeface designed as
+      an intermediate style between the modern and traditional. It is
+      intended to be a multi-purpose digital font for user interface
+      designs, digital content, reading on laptops, mobile devices, and
+      electronic books. Noto Serif CJK comprehensively covers
+      Simplified Chinese, Traditional Chinese, Japanese, and Korean in a
+      unified font family. It supports regional variants of ideographic
+      characters for each of the four languages. In addition, it supports
+      Japanese kana, vertical forms, and variant characters (itaiji); it
+      supports Korean hangeul — both contemporary and archaic.
+    '';
+    license = licenses.ofl;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ mathnerd314 emily ];
+  };
+}